summaryrefslogtreecommitdiffstats
path: root/network/pptpd/pptpd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/pptpd/pptpd.SlackBuild')
-rw-r--r--network/pptpd/pptpd.SlackBuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/network/pptpd/pptpd.SlackBuild b/network/pptpd/pptpd.SlackBuild
index 25407b7454..89551690d7 100644
--- a/network/pptpd/pptpd.SlackBuild
+++ b/network/pptpd/pptpd.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pptpd
-# Copyright 2007,2008 Robby Workman, Northport, Alabama, USA
+# Copyright 2007-2009 Robby Workman, Northport, Alabama, USA
# All rights reserved.
#
@@ -36,10 +36,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -59,10 +62,12 @@ find . \
# Fix the plugins Makefile
patch -p1 < $CWD/plugins_Makefile.diff
+sed -i "s%@baselibdir@%$lib${LIBDIRSUFFIX}%" plugins/Makefile
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
@@ -87,8 +92,9 @@ cat samples/options.pptpd > $PKG/etc/ppp/options.pptpd.new
cat samples/chap-secrets > $PKG/etc/ppp/chap-secrets.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO \
- html tools debian $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO html tools debian \
+ $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc -type f -exec chmod 0644 {} \;
find $PKG/usr/doc -type d -name 'CVS' | xargs rm -rf
@@ -97,4 +103,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}