summaryrefslogtreecommitdiffstats
path: root/network/pptpd/patches/plugins_Makefile.diff
diff options
context:
space:
mode:
Diffstat (limited to 'network/pptpd/patches/plugins_Makefile.diff')
-rw-r--r--network/pptpd/patches/plugins_Makefile.diff30
1 files changed, 30 insertions, 0 deletions
diff --git a/network/pptpd/patches/plugins_Makefile.diff b/network/pptpd/patches/plugins_Makefile.diff
new file mode 100644
index 0000000000..52d4134a90
--- /dev/null
+++ b/network/pptpd/patches/plugins_Makefile.diff
@@ -0,0 +1,30 @@
+--- pptpd-1.3.4/plugins/Makefile 2008-07-20 01:46:35.836374075 -0500
++++ pptpd-1.3.4/plugins/Makefile 2008-07-20 01:48:48.729656656 -0500
+@@ -3,7 +3,7 @@
+ CFLAGS = $(COPTS) -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ LDADD = -lutil
+-INSTALL = install -o root
++INSTALL = install
+ prefix = /usr/local
+
+ PLUGINS = pptpd-logwtmp.so
+@@ -18,14 +18,14 @@
+ %.so: %.c
+ $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
+
+-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
++LIBDIR ?= $(prefix)/@baselibdir@/pptpd
+
+ install: $(PLUGINS)
+- $(INSTALL) -d $(LIBDIR)
+- $(INSTALL) $? $(LIBDIR)
++ $(INSTALL) -d $(DESTDIR)/$(LIBDIR)
++ $(INSTALL) $? $(DESTDIR)/$(LIBDIR)
+
+ uninstall:
+- rm -f $(LIBDIR)$(PLUGINS)
++ rm -f $(DESTDIR)/$(LIBDIR)$(PLUGINS)
+
+ clean:
+ rm -f *.o *.so *.a