summaryrefslogtreecommitdiffstats
path: root/network/libressl
diff options
context:
space:
mode:
Diffstat (limited to 'network/libressl')
-rw-r--r--network/libressl/README75
-rw-r--r--network/libressl/libressl.SlackBuild108
-rw-r--r--network/libressl/libressl.info12
-rw-r--r--network/libressl/slack-desc19
4 files changed, 214 insertions, 0 deletions
diff --git a/network/libressl/README b/network/libressl/README
new file mode 100644
index 0000000000..e2ef33ecf2
--- /dev/null
+++ b/network/libressl/README
@@ -0,0 +1,75 @@
+LibreSSL is a fork of OpenSSL 1.0.1g developed by the OpenBSD project.
+Our goal is to modernize the codebase, improve security, and apply best
+practice development processes from OpenBSD.
+
+The binaries are installed as libressl-openssl, libressl-ocspcheck, and
+libressl-nc.
+
+************************************************************************
+NOTE! This contains libtls so the standalone libtls package should be
+removed before building and installing libressl.
+************************************************************************
+
+Compatibility with OpenSSL:
+
+LibreSSL is API compatible with OpenSSL 1.0.1, but does not yet include
+all new APIs from OpenSSL 1.0.2 and later. LibreSSL also includes APIs
+not yet present in OpenSSL. The current common API subset is OpenSSL
+1.0.1.
+
+LibreSSL is not ABI compatible with any release of OpenSSL, or
+necessarily earlier releases of LibreSSL. You will need to relink your
+programs to LibreSSL in order to use it, just as in moving between major
+versions of OpenSSL. LibreSSL's installed library version numbers are
+incremented to account for ABI and API changes.
+
+Compatibility with other operating systems:
+
+While primarily developed on and taking advantage of APIs available on
+OpenBSD, the LibreSSL portable project attempts to provide working
+alternatives for other operating systems, and assists with improving
+OS-native implementations where possible.
+
+At the time of this writing, LibreSSL is known to build and work on:
+
+* Linux (kernel 3.17 or later recommended)
+* FreeBSD (tested with 9.2 and later)
+* NetBSD (7.0 or later recommended)
+* HP-UX (11i)
+* Solaris (11 and later preferred)
+* Mac OS X (tested with 10.8 and later)
+* AIX (5.3 and later)
+
+LibreSSL also supports the following Windows environments:
+* Microsoft Windows (Windows 7 / Windows Server 2008r2 or later, x86 and
+ x64)
+* Wine (32-bit and 64-bit)
+* Mingw-w64, Cygwin, and Visual Studio
+
+Please report bugs either to the public libressl@openbsd.org mailing
+list, or to the github
+
+Severe vulnerabilities or bugs requiring coordination with OpenSSL can
+be sent to the core team at libressl-security@openbsd.org.
+
+OPTIONS:
+
+By default a minimal set of man pages are installed:
+
+/usr/man/man1/libressl-nc
+/usr/man/man1/libressl-openssl
+/usr/man/man8/libressl-ocspcheck
+
+To install them all, use:
+
+MANPAGES=yes ./libressl.SlackBuild
+
+========================================================================
+
+MAINTAINER NOTES
+
+NOTE: PKG_CONFIG_PATH will likely need setting in your build scripts:
+
+PKG_CONFIG_PATH=/usr/lib$LIBDIRSUFFIX/libressl/pkgconfig:$PKG_CONFIG_PATH
+
+========================================================================
diff --git a/network/libressl/libressl.SlackBuild b/network/libressl/libressl.SlackBuild
new file mode 100644
index 0000000000..4572cfb570
--- /dev/null
+++ b/network/libressl/libressl.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/bash
+
+# slackbuild script for libressl
+# By D Woodfall <dave@slackbuilds.org>
+# Licensed under the WTFPL (http://www.wtfpl.net)
+#
+# 2023-04-18 12:11:51 +0100 Thanks to Naglfar: --with-openssldir=/etc/$PRGNAM
+# 2023-05-10 12:04:05 +0100 Remove ld.so.conf stuff.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libressl
+VERSION=${VERSION:-3.7.1}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + \
+ -o \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+# Don't install man page symlinks
+sed -i '/ln -sf.*\.3"$/d' man/Makefile.in
+
+if [ "${MANPAGES:-no}" = no ]; then
+ sed -i '/man\/Makefile/d' configure.ac
+ autoreconf -f
+ sed -i "s, man , ,g; s, install-man , ,g" Makefile.in
+fi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --enable-nc \
+ --disable-tests \
+ --disable-static \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX}/$PRGNAM \
+ --includedir=/usr/include/$PRGNAM \
+ --with-openssldir=/etc/$PRGNAM \
+ --program-prefix "$PRGNAM-" \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM/*.la
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING ChangeLog README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/$PRGNAM-$VERSION-relnotes.txt > \
+ $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-$VERSION-relnotes.txt
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/libressl/libressl.info b/network/libressl/libressl.info
new file mode 100644
index 0000000000..ca19db9fe0
--- /dev/null
+++ b/network/libressl/libressl.info
@@ -0,0 +1,12 @@
+PRGNAM="libressl"
+VERSION="3.7.1"
+HOMEPAGE="https://www.libressl.org"
+DOWNLOAD="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.7.1.tar.gz \
+ https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.7.1-relnotes.txt"
+MD5SUM="133f11e478f46528414245dccb6355f2 \
+ 0b1e4784b5c3b2672c9e7432e11d1fa3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="D Woodfall"
+EMAIL="dave@slackbuilds.org"
diff --git a/network/libressl/slack-desc b/network/libressl/slack-desc
new file mode 100644
index 0000000000..0e240ea20a
--- /dev/null
+++ b/network/libressl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libressl: libressl (OpenSSL fork by OpenBSD)
+libressl:
+libressl: LibreSSL is a fork of OpenSSL 1.0.1g developed by the OpenBSD
+libressl: project. Our goal is to modernize the codebase, improve security,
+libressl: and apply best practice development processes from OpenBSD.
+libressl:
+libressl: https://www.libressl.org
+libressl:
+libressl:
+libressl:
+libressl: