summaryrefslogtreecommitdiffstats
path: root/network/gophernicus/gophernicus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/gophernicus/gophernicus.SlackBuild')
-rw-r--r--network/gophernicus/gophernicus.SlackBuild30
1 files changed, 22 insertions, 8 deletions
diff --git a/network/gophernicus/gophernicus.SlackBuild b/network/gophernicus/gophernicus.SlackBuild
index fea7b7593a..ab8ca83fee 100644
--- a/network/gophernicus/gophernicus.SlackBuild
+++ b/network/gophernicus/gophernicus.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for Gophernicus
-# Copyright 2012-2015 Fridrich von Stauffenberg <cancellor2@gmail.com>
+# Copyright 2012-2015 Fridrich von Stauffenberg <email removed>
+# Copyright 2018 B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,8 +23,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20180722 bkw:
+# - Take over maintenance.
+# - Update for latest upstream 'rolling release' version.
+# - Port old Makefile.patch to latest release. Also fix it so
+# parallel makes work (no more -j1).
+# - Change HOMEPAGE to a non-gopher URL (ugh).
+# - Don't install compile instructions in doc dir.
+# - Add git2tarxz.sh to make upgrading easier in the future.
+
PRGNAM=gophernicus
-VERSION=${VERSION:-2.5}
+VERSION=${VERSION:-2.5v101}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,23 +66,27 @@ fi
set -e
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
+find -L . -perm /111 -exec chmod 755 {} + -o -exec chmod 644 {} +
patch -p1 < $CWD/Makefile.patch
-make CFLAGS="$SLKCFLAGS" -j1
-make install DESTDIR=$PKG
+# 'make install' strips the binary already.
+make all CFLAGS="$SLKCFLAGS"
+make install DOCDIR="$PKGDOC" DESTDIR=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Don't need this:
+rm -f $PKGDOC/INSTALL
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc