summaryrefslogtreecommitdiffstats
path: root/network/ganglia/ganglia.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/ganglia/ganglia.SlackBuild')
-rw-r--r--network/ganglia/ganglia.SlackBuild112
1 files changed, 0 insertions, 112 deletions
diff --git a/network/ganglia/ganglia.SlackBuild b/network/ganglia/ganglia.SlackBuild
deleted file mode 100644
index f953957ead..0000000000
--- a/network/ganglia/ganglia.SlackBuild
+++ /dev/null
@@ -1,112 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for ganglia
-#
-# Copyright 2008 Cherife Li <cherife-#-dotimes.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ganglia
-VERSION=3.1.1
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-WWWPATH=${WWWPATH:-/var/www/htdocs/gweb}
-DOCUMENTATION="AUTHORS COPYING ChangeLog INSTALL NEWS README*"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-if [ -n "$OPT" ]; then
- if [ "$OPT" = 'gmetad' ]; then
- OPT='--with-gmetad'
- else
- unset -v OPT
- fi
-fi
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --enable-static=no \
- --enable-gexeca \
- --enable-status \
- $OPT
-
-make
-make install DESTDIR=$PKG
-
-mkdir -p $PKG/etc/rc.d
-cat gmond/gmond.init > $PKG/etc/rc.d/rc.gmond.new
-./gmond/gmond -t > $PKG/etc/gmond.conf.new
-
-if [ -n "$OPT" ]; then
- cat gmetad/gmetad.init > $PKG/etc/rc.d/rc.gmetad.new
- cat gmetad/gmetad.conf > $PKG/etc/gmetad.conf.new
-fi
-
-mkdir -p $PKG/$WWWPATH
-mv web/* $PKG/$WWWPATH
-( cd $PKG/$WWWPATH ; rm -f AUTHORS COPYING Makefile.am conf.php.in version.php.in )
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCUMENTATION $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/usr/man/man1
-cp -a mans/*.1 $PKG/usr/man/man1
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz