summaryrefslogtreecommitdiffstats
path: root/network/flexget/flexget.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/flexget/flexget.SlackBuild')
-rw-r--r--network/flexget/flexget.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
index 4d7ad25158..fe6463a10e 100644
--- a/network/flexget/flexget.SlackBuild
+++ b/network/flexget/flexget.SlackBuild
@@ -28,7 +28,7 @@
SRCNAM=FlexGet
PRGNAM=${SRCNAM,,}
-VERSION=${VERSION:-1.2.358}
+VERSION=${VERSION:-2.2.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,7 +39,7 @@ OUTPUT=${OUTPUT:-/tmp}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
*) export ARCH=$( uname -m ) ;;
esac
@@ -58,7 +58,10 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix requirement 'flask-restplus' working with newer version
+sed -i "s/restplus=/restplus>/" requirements.txt
python setup.py install --root=$PKG