summaryrefslogtreecommitdiffstats
path: root/network/dsniff/patches/35_Add_CPPFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'network/dsniff/patches/35_Add_CPPFLAGS.patch')
-rw-r--r--network/dsniff/patches/35_Add_CPPFLAGS.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/network/dsniff/patches/35_Add_CPPFLAGS.patch b/network/dsniff/patches/35_Add_CPPFLAGS.patch
new file mode 100644
index 0000000000..3ea8eb94d7
--- /dev/null
+++ b/network/dsniff/patches/35_Add_CPPFLAGS.patch
@@ -0,0 +1,50 @@
+Description: import CPPFLAGS in order to build an ELF binary that uses fortified libc functions. Now it is built with all default Debian compiler flags.
+Author: Marcos Fouces <marcos.fouces@gmail.com>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,12 +11,13 @@
+ install_prefix =
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+-libdir = $(prefix)/share/dsniff
++libdir = @libdir@
+ sbindir = @sbindir@
+ mandir = @mandir@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@ -DDSNIFF_LIBDIR=\"$(libdir)/\"
++CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+
+ PCAPINC = @PCAPINC@
+@@ -37,7 +38,8 @@
+ X11INC = @X_CFLAGS@
+ X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
+
+-INCS = -I. $(X11INC) -I$(srcdir)/missing
++INCS = -I. $(NIDSINC) $(PCAPINC) $(LNETINC) $(DBINC) $(SSLINC) $(X11INC) \
++ -I$(srcdir)/missing
+ LIBS = @LIBS@ -L$(srcdir) -lmissing
+
+ INSTALL = @INSTALL@
+@@ -73,7 +75,7 @@
+ CONFIGS = dsniff.magic dsniff.services dnsspoof.hosts
+
+ .c.o:
+- $(CC) $(CFLAGS) $(INCS) -c $(srcdir)/$*.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCS) -c $(srcdir)/$*.c
+
+ all: $(PROGS)
+
+@@ -98,7 +100,7 @@
+ filesnarf.o: nfs_prot.h
+
+ $(LIBOBJS):
+- $(CC) $(CFLAGS) $(INCS) -c $(srcdir)/missing/$*.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCS) -c $(srcdir)/missing/$*.c
+
+ libmissing.a: $(LIBOBJS)
+ ar -cr $@ $(LIBOBJS)