summaryrefslogtreecommitdiffstats
path: root/network/dsniff/patches/20_debian_dirs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'network/dsniff/patches/20_debian_dirs.patch')
-rw-r--r--network/dsniff/patches/20_debian_dirs.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/network/dsniff/patches/20_debian_dirs.patch b/network/dsniff/patches/20_debian_dirs.patch
new file mode 100644
index 0000000000..a99a3ff57d
--- /dev/null
+++ b/network/dsniff/patches/20_debian_dirs.patch
@@ -0,0 +1,62 @@
+Author: Steve Kemp <skx@debian.org>
+Description: Adapt to Debian directory structure.
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,7 +11,7 @@
+ install_prefix =
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+-libdir = @libdir@
++libdir = $(prefix)/share/dsniff
+ sbindir = @sbindir@
+ mandir = @mandir@
+
+@@ -37,8 +37,7 @@
+ X11INC = @X_CFLAGS@
+ X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
+
+-INCS = -I. $(NIDSINC) $(PCAPINC) $(LNETINC) $(DBINC) $(SSLINC) $(X11INC) \
+- -I$(srcdir)/missing
++INCS = -I. $(X11INC) -I$(srcdir)/missing
+ LIBS = @LIBS@ -L$(srcdir) -lmissing
+
+ INSTALL = @INSTALL@
+--- a/dnsspoof.8
++++ b/dnsspoof.8
+@@ -31,7 +31,7 @@
+ address queries on the LAN with an answer of the local machine's IP
+ address.
+ .SH FILES
+-.IP \fI/usr/local/lib/dnsspoof.hosts\fR
++.IP \fI/usr/share/dsniff/dnsspoof.hosts\fR
+ Sample hosts file.
+ .SH "SEE ALSO"
+ dsniff(8), hosts(5)
+--- a/dsniff.8
++++ b/dsniff.8
+@@ -68,9 +68,9 @@
+ On a hangup signal \fBdsniff\fR will dump its current trigger table to
+ \fIdsniff.services\fR.
+ .SH FILES
+-.IP \fI/usr/local/lib/dsniff.services\fR
++.IP \fI/usr/share/dsniff/dsniff.services\fR
+ Default trigger table
+-.IP \fI/usr/local/lib/dsniff.magic\fR
++.IP \fI/usr/share/dsniff/dsniff.magic\fR
+ Network protocol magic
+ .SH "SEE ALSO"
+ arpspoof(8), libnids(3), services(5), magic(5)
+--- a/pathnames.h
++++ b/pathnames.h
+@@ -12,7 +12,7 @@
+ #define PATHNAMES_H
+
+ #ifndef DSNIFF_LIBDIR
+-#define DSNIFF_LIBDIR "/usr/local/lib/"
++#define DSNIFF_LIBDIR "/usr/share/dsniff/"
+ #endif
+
+ #define DSNIFF_SERVICES "dsniff.services"