summaryrefslogtreecommitdiffstats
path: root/network/dillo/dillo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/dillo/dillo.SlackBuild')
-rw-r--r--network/dillo/dillo.SlackBuild33
1 files changed, 28 insertions, 5 deletions
diff --git a/network/dillo/dillo.SlackBuild b/network/dillo/dillo.SlackBuild
index 58d98dbcef..f005cb24c5 100644
--- a/network/dillo/dillo.SlackBuild
+++ b/network/dillo/dillo.SlackBuild
@@ -1,12 +1,29 @@
#!/bin/sh
-# Slackware build script for dillo. It has NOT been tested on x86_64.
+# Slackware build script for dillo.
-# Maintainer: Mikhail Zotov
-# Public domain
+# Copyright 2012 John Berger <insomniactoo@localnet.com>, TN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dillo
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-3.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,11 +69,17 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+sed -i 's/fltk-config/fltk13-config/g' configure.in
+autoreconf
+
+ #https and ssl are in the alpha stage, but if you don't want to try and use it
+ #just delete or comment out --enable-ssl
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
+ --enable-ssl \
--prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --libdir=/usr/lib${LIBDIRSUFFIX}/fltk13 \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \