summaryrefslogtreecommitdiffstats
path: root/network/cherokee
diff options
context:
space:
mode:
Diffstat (limited to 'network/cherokee')
-rw-r--r--network/cherokee/README4
-rw-r--r--network/cherokee/cherokee.SlackBuild30
-rw-r--r--network/cherokee/cherokee.info10
3 files changed, 29 insertions, 15 deletions
diff --git a/network/cherokee/README b/network/cherokee/README
index 7214e5a3d4..c2428de130 100644
--- a/network/cherokee/README
+++ b/network/cherokee/README
@@ -37,7 +37,7 @@ Notes about using this SlackBuild
to the script.
5) If you want to build Cherokee with debugging options, enable trace
facility by passing TRACE=yes to the script.
-6) The $WWWGROUP group and the $WWWUSER user account are set to cherokee.
+6) The $WWWGROUP group and $WWWUSER user account are set to cherokee.
To run cherokee as a different user/group specify them passing the
options WWWUSER/WWWGROUP to the slackbuild, like
@@ -48,7 +48,7 @@ Notes about using this SlackBuild
groupadd -g 306 cherokee
useradd -u 306 -g cherokee -d /var/www/htdocs-cherokee cherokee
- See http://slackbuilds.org/uid_gid.txt for current reccomendations (if any)
+ See http://slackbuilds.org/uid_gid.txt for current reccomendations.
7) If you want to use it with php, remember to add your user to the
apache group, so that it can use /var/lib/php, like
diff --git a/network/cherokee/cherokee.SlackBuild b/network/cherokee/cherokee.SlackBuild
index ee57d2b98a..207850d16f 100644
--- a/network/cherokee/cherokee.SlackBuild
+++ b/network/cherokee/cherokee.SlackBuild
@@ -1,29 +1,39 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for cherokee
# Written by Pablo Hernan Saro (pablosaro@gmail.com)
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=cherokee
-VERSION=${VERSION:-20131105_d91c9c1}
+VERSION=${VERSION:-20230111_ce1ca8a}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -86,6 +96,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|\[2\.71|[2.69|" configure.ac m4/{nls,po,progtest}.m4
+
# Apply all the patches in $CWD/patches (thanks Gentoo)
for patch in $CWD/patches/* ; do
patch -p1 < $patch
@@ -107,7 +119,7 @@ CXXFLAGS="$SLKCFLAGS" \
--with-mysql=$MYSQL \
--enable-ipv6=$IPV6 \
--enable-admin=$ADMIN \
- --disable-pam \
+ --enable-pam \
--disable-static \
--enable-trace=$TRACE
@@ -130,9 +142,11 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
install -D -m 0755 $CWD/rc.$PRGNAM $PKG/etc/rc.d/rc.$PRGNAM.new
mv $PKG/etc/cherokee/cherokee.conf $PKG/etc/cherokee/cherokee.conf.new
+rm -f $PKG/usr/lib*/*.la
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/cherokee/cherokee.info b/network/cherokee/cherokee.info
index ea23a977c6..83b3c5d9bd 100644
--- a/network/cherokee/cherokee.info
+++ b/network/cherokee/cherokee.info
@@ -1,10 +1,10 @@
PRGNAM="cherokee"
-VERSION="20131105_d91c9c1"
+VERSION="20230111_ce1ca8a"
HOMEPAGE="http://www.cherokee-project.com"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/cherokee-20131105_d91c9c1.tar.xz"
-MD5SUM="845ed7bdb3b038d277607a47288aaec1"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/cherokee-20230111_ce1ca8a.tar.xz"
+MD5SUM="f78e7cf58fd398a7207e537b98e6d14d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Pablo Hernan Saro"
-EMAIL="pablosaro@gmail.com"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"