summaryrefslogtreecommitdiffstats
path: root/network/amap/slackware.diff
diff options
context:
space:
mode:
Diffstat (limited to 'network/amap/slackware.diff')
-rw-r--r--network/amap/slackware.diff40
1 files changed, 14 insertions, 26 deletions
diff --git a/network/amap/slackware.diff b/network/amap/slackware.diff
index dc3fa3c449..ba47698b88 100644
--- a/network/amap/slackware.diff
+++ b/network/amap/slackware.diff
@@ -1,6 +1,6 @@
-diff -Naur amap-5.2.orig/Makefile.am amap-5.2/Makefile.am
---- amap-5.2.orig/Makefile.am 2005-09-22 17:39:18.000000000 +0200
-+++ amap-5.2/Makefile.am 2009-03-03 13:48:56.000000000 +0100
+diff -Naur amap-5.4.orig/Makefile.am amap-5.4/Makefile.am
+--- amap-5.4.orig/Makefile.am 2011-04-20 17:10:17.000000000 +0200
++++ amap-5.4/Makefile.am 2011-09-01 12:25:40.374265928 +0200
@@ -1,13 +1,13 @@
CC=gcc
-LIB=-lpcre -L./pcre-3.9/ -I./pcre-3.9/
@@ -40,13 +40,13 @@ diff -Naur amap-5.2.orig/Makefile.am amap-5.2/Makefile.am
+ -test -e amap.exe && cp -f amap.exe amapcrap.exe $(DESTDIR)$(PREFIX)$(BINDIR) || echo
+ -cp -f $(SCRIPTS) $(DESTDIR)$(PREFIX)$(DATADIR)
+ -cp -f $(MANPAGE) $(DESTDIR)$(PREFIX)$(MANDIR)
-+ -test $(DESTDIR)$(PREFIX)$(BINDIR)/amap6 || cd $(DESTDIR)$(PREFIX)$(BINDIR) && ln -s amap amap6 || true
++ -test $(DESTDIR)$(PREFIX)$(BINDIR)/amap6 || cd $(DESTDIR)$(PREFIX)$(BINDIR) && ln -s amap amap6
clean:
cd pcre-3.9 && make clean
-diff -Naur amap-5.2.orig/amap-inc.h amap-5.2/amap-inc.h
---- amap-5.2.orig/amap-inc.h 2003-10-29 23:37:41.000000000 +0100
-+++ amap-5.2/amap-inc.h 2009-03-03 13:49:14.000000000 +0100
+diff -Naur amap-5.4.orig/amap-inc.h amap-5.4/amap-inc.h
+--- amap-5.4.orig/amap-inc.h 2011-04-20 17:10:17.000000000 +0200
++++ amap-5.4/amap-inc.h 2011-09-01 12:23:29.709474562 +0200
@@ -20,7 +20,7 @@
#include <errno.h>
#include <sys/resource.h>
@@ -56,9 +56,9 @@ diff -Naur amap-5.2.orig/amap-inc.h amap-5.2/amap-inc.h
#ifdef OPENSSL
#include <openssl/ssl.h>
#include <openssl/err.h>
-diff -Naur amap-5.2.orig/amap-lib.c amap-5.2/amap-lib.c
---- amap-5.2.orig/amap-lib.c 2005-09-07 23:22:24.000000000 +0200
-+++ amap-5.2/amap-lib.c 2009-03-03 13:49:17.000000000 +0100
+diff -Naur amap-5.4.orig/amap-lib.c amap-5.4/amap-lib.c
+--- amap-5.4.orig/amap-lib.c 2011-04-20 17:10:17.000000000 +0200
++++ amap-5.4/amap-lib.c 2011-09-01 12:24:09.751491082 +0200
@@ -306,7 +306,7 @@
strcpy(file_name, AMAP_PREFIX);
if (file_name[strlen(file_name) - 1] != '/')
@@ -68,7 +68,7 @@ diff -Naur amap-5.2.orig/amap-lib.c amap-5.2/amap-lib.c
strcat(file_name, AMAP_DEFAULT_FILENAME);
strcat(file_name, extension);
f = fopen(file_name, "r");
-@@ -2032,9 +2032,9 @@
+@@ -2058,9 +2058,9 @@
if (opt->update) {
printf("Running Online Update for fingerprints, connecting to %s\n", AMAP_RESOURCE);
if (opt->filename == NULL) {
@@ -80,21 +80,9 @@ diff -Naur amap-5.2.orig/amap-lib.c amap-5.2/amap-lib.c
strcat(opt->filename, AMAP_DEFAULT_FILENAME);
}
opt->file_log = malloc(strlen(opt->filename) + 6);
-diff -Naur amap-5.2.orig/amap.h amap-5.2/amap.h
---- amap-5.2.orig/amap.h 2005-09-08 00:08:57.000000000 +0200
-+++ amap-5.2/amap.h 2009-03-03 13:49:06.000000000 +0100
-@@ -22,7 +22,7 @@
- #define AMAP_YEAR "2005"
- #define AMAP_AUTHOR "van Hauser"
- #define AMAP_EMAIL "amap-dev@thc.org"
--#define AMAP_RESOURCE "www.thc.org/thc-amap"
-+#define AMAP_RESOURCE "freeworld.thc.org/thc-amap"
-
- #ifndef AMAP_PREFIX
- #ifdef PREFIX
-diff -Naur amap-5.2.orig/configure amap-5.2/configure
---- amap-5.2.orig/configure 2005-06-03 15:34:19.000000000 +0200
-+++ amap-5.2/configure 2009-03-03 13:49:22.000000000 +0100
+diff -Naur amap-5.4.orig/configure amap-5.4/configure
+--- amap-5.4.orig/configure 2011-04-20 17:10:17.000000000 +0200
++++ amap-5.4/configure 2011-09-01 12:24:22.359181454 +0200
@@ -152,17 +152,6 @@
XLIBS="$XLIBS -lresolv"
fi