summaryrefslogtreecommitdiffstats
path: root/multimedia/openshot/openshot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/openshot/openshot.SlackBuild')
-rw-r--r--multimedia/openshot/openshot.SlackBuild28
1 files changed, 22 insertions, 6 deletions
diff --git a/multimedia/openshot/openshot.SlackBuild b/multimedia/openshot/openshot.SlackBuild
index 5c118c1ff2..fc9a23f40b 100644
--- a/multimedia/openshot/openshot.SlackBuild
+++ b/multimedia/openshot/openshot.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Copyright 2009, Jonathan Larsen (agentc0re), SLC, UT
# Contact Info: agentc0re 'AT' learnix 'DOT' net
#
-# Copyright 2016-2019 Christoph Willing, Brisbane Australia
+# Copyright 2016-2023 Christoph Willing, Brisbane Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -41,14 +41,21 @@
# Oct 2nd, 2012
# Version upgrade to 1.4.3 - Matteo Bernardini <ponce@slackbuilds.org>
#
-# From Oct 22nd, 2016-2019
+# From Oct 22nd, 2016-2020
# Maintenance & various version upgrades - Christoph Willing <chris.willing@linux.com>
+# 20220421 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - add gtk-update-icon-cache to doinst.sh.
+# - stop writing outside of $TMP (except /root/.openshot_qt/).
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=openshot
SRCNAM=openshot-qt
-VERSION=${VERSION:-2.4.4}
+VERSION=${VERSION:-3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -58,7 +65,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -93,6 +104,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# 20220421 bkw: setup.py doesn't need to call update-mime-database and
+# update-desktop-database; it spams the real /usr, and our doinst.sh
+# already does the job.
+sed -i '/^if ROOT and/,$d' setup.py
+
python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
@@ -109,4 +125,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE