summaryrefslogtreecommitdiffstats
path: root/multimedia/mlt
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mlt')
-rw-r--r--multimedia/mlt/README11
-rw-r--r--multimedia/mlt/doinst.sh20
-rw-r--r--multimedia/mlt/mlt.SlackBuild217
-rw-r--r--multimedia/mlt/mlt.info10
-rw-r--r--multimedia/mlt/slack-desc19
5 files changed, 0 insertions, 277 deletions
diff --git a/multimedia/mlt/README b/multimedia/mlt/README
deleted file mode 100644
index 5177fadcb4..0000000000
--- a/multimedia/mlt/README
+++ /dev/null
@@ -1,11 +0,0 @@
-MLT is an open source multimedia framework, designed and developed for
-television broadcasting. It provides a toolkit for broadcasters, video
-editors, media players, transcoders, web streamers and many more types
-of applications. The functionality of the system is provided via an
-assortment of ready to use tools, XML authoring components, and an
-extensible plug-in based API.
-
-Optional dependencies are qt5, ladspa_sdk, frei0r, swfdec and jack-rack.
-
-The build script autodetect language interpreters on your system
-and build the relative bindings.
diff --git a/multimedia/mlt/doinst.sh b/multimedia/mlt/doinst.sh
deleted file mode 100644
index a069af7fb1..0000000000
--- a/multimedia/mlt/doinst.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
diff --git a/multimedia/mlt/mlt.SlackBuild b/multimedia/mlt/mlt.SlackBuild
deleted file mode 100644
index f2f9273682..0000000000
--- a/multimedia/mlt/mlt.SlackBuild
+++ /dev/null
@@ -1,217 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for mlt.
-
-# Written by stormtracknole - stormtracknole@gmail.com
-# Modified by Erik Hanson (erik@slackbuilds.org) with
-# help from Jonathan Larsen (agentc0re@learnix.net)
-# Maintatiner: Edward W. Koenig <kingbeowulf@gmail.com>
-#
-# Feb 16, 2010 - Modified the script and defined the $PYTHON variable
-# outside of the if statement because it was causing issues with
-# the other if statement that also relies on it's answer.
-# - Fixed the second PYTHON if statement that finds the site package
-# directory. Added parentheses around the part that cd's into the
-# python swig src to copy the files to the site packages so that it
-# would interfere with the CWD before it
-#
-# +---------------------------------------+
-# Mar 3rd, 2010
-# *Version upgrade to 0.5.2
-# *fixed the "strip" for bash 4
-# compatability
-# +---------------------------------------+
-# Sept 12, 2010
-# *Version upgrade to 0.5.6
-# *Bug fixes and enhancements added
-# +---------------------------------------+
-# May 16, 2011
-# *Version upgrade to 0.7.2
-# +---------------------------------------+
-# Dec 14, 2011
-# *Version upgrade to 0.7.6
-# *Bug fixes
-# +---------------------------------------+
-# Jul 2, 2012
-# *Version upgrade to 0.8.0
-# *Bug fixes
-# +---------------------------------------+
-# Apr 2, 2013
-# *Version upgrade to 0.8.8
-# *Added frei0r as a dependency
-# +---------------------------------------+
-# Jun 9, 2015
-# *Version upgrade to 0.9.6
-# *Fixed lua portion of the code
-# thanks to John Vogel.
-# +---------------------------------------+
-# 20-MAR-2016 new maintainer, version update to 6.0.0
-# 11-OCT-2016 version update
-# 22-OCT-2016 add qt5 support, bug fixes/addenda (Larry Hajali)
-# 29-JAN-2017 version update
-# 16-APR-2017 Compiling with vdpau is no longer supported ffmpeg-3.x
-# 08-AUG-2018 version update, remove qt5 patch
-# 16-APR-2019 version update
-# 14-JUL-2019 version update
-
-PRGNAM=mlt
-VERSION=${VERSION:-6.16.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-# Autodetect which SWIG Languages bindings to build
-# according to what's installed on the system:
-if [ -f "$(which javac)" ]; then java="java"; else java=""; fi
-if [ -f "$(which lua)" ]; then lua="lua"; else lua=""; fi
-if [ -f "$(which perl)" ]; then perl="perl"; else perl=""; fi
-if [ -f "$(which php)" ]; then php="php"; else php=""; fi
-if [ -f "$(which python)" ]; then python="python"; else python=""; fi
-if [ -h "$(which tclsh)" ]; then tcl="tcl"; else tcl=""; fi
-if [ -f "$(which csharp)" ]; then csharp="csharp"; else csharp=""; fi
-if [ -f "$(which ruby)" ]; then ruby="ruby"; else ruby=""; fi
-
-# Use qt5 if present, otherwise system default
-if pkg-config --exists Qt5 ; then
- qt="--qt-libdir=$(pkg-config Qt5 --variable=libdir)
- --qt-includedir=$(pkg-config Qt5 --variable=headerdir)"
-else
- qt="--qt-libdir=$(pkg-config Qt --variable=libdir)
- --qt-includedir=$(pkg-config Qt --variable=headerdir)"
-fi
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --disable-debug \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --enable-gpl \
- --enable-gpl3 \
- --luma-compress \
- --enable-motion-est \
- $qt \
- --swig-languages="$java $lua $perl $php $python $ruby $tcl $csharp" \
- --build=$ARCH-slackware-linux
-
-# qt5 fixup thanks to AlienBOB!
-sed -i -e 's/CXXFLAGS :=/CXXFLAGS := --std=c++11/' src/modules/qt/Makefile
-
-make clean
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
-make install DESTDIR=$PKG
-
-# Install built bindings
-if [ "$lua" ]; then
- ( cd $TMP/$PRGNAM-$VERSION/src/swig/lua
- install -D -m 0755 mlt.so $PKG/$(pkg-config --variable INSTALL_CMOD lua)/mlt.so
- install -D -m 0644 play.lua $PKG/usr/doc/$PRGNAM-$VERSION/play.lua
- )
-fi
-if [ "$perl" ]; then
- ( cd $TMP/$PRGNAM-$VERSION/src/swig/perl
- install -D -m 0644 mlt.pm $PKG/usr/share/perl5/mlt.pm
- install -D -m 0755 play.pl $PKG/usr/share/perl5/play.pl
- install -D -m 0755 blib/arch/auto/mlt/mlt.so \
- $PKG/usr/lib$LIBDIRSUFFIX/perl5/auto/mlt/mlt.so
- install -D -m 0644 mlt.bs \
- $PKG/usr/lib$LIBDIRSUFFIX/perl5/auto/mlt/mlt.bs
- )
-fi
-if [ "$php" ]; then
- ( cd $TMP/$PRGNAM-$VERSION/src/swig/php
- install -D -m 0755 mlt.so $PKG/usr/lib$LIBDIRSUFFIX/php/extensions/mlt.so
- install -D -m 0644 play.php $PKG/usr/doc/$PRGNAM-$VERSION/play.php
- mkdir -p $PKG/etc/php.d
- cat > $PKG/etc/php.d/$PRGNAM.ini.new << EOF
-; Enable mlt extension module
-; extension=$PRGNAM.so
-EOF
- )
-fi
-if [ "$python" ]; then
- PYTHONSITEPKG=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
- ( cd $TMP/$PRGNAM-$VERSION/src/swig/python
- install -D -m 0755 _mlt.so $PKG/$PYTHONSITEPKG/_mlt.so
- install -D -m 0755 mlt.py $PKG/$PYTHONSITEPKG/mlt.py
- install -D -m 0755 play.py $PKG/usr/doc/$PRGNAM-$VERSION/play.py
- )
-fi
-if [ "$ruby" ]; then
- ( cd $TMP/$PRGNAM-$VERSION/src/swig/ruby
- install -D -m 0755 mlt.so \
- $PKG$(ruby -e 'print RbConfig::CONFIG["sitearchdir"]')/mlt.so
- install -D -m 0755 play.rb $PKG/usr/doc/$PRGNAM-$VERSION/play.rb
- install -D -m 0755 thumbs.rb $PKG/usr/doc/$PRGNAM-$VERSION/thumbs.rb
- )
-fi
-if [ "$tcl" ]; then
- ( cd $TMP/$PRGNAM-$VERSION/src/swig/tcl
- . /usr/lib$LIBDIRSUFFIX/tclConfig.sh
- install -D -m 0755 mlt.so \
- $PKG/usr/lib$LIBDIRSUFFIX/tcl$TCL_MAJOR_VERSION/$TCL_VERSION/mlt.so
- install -D -m 0755 play.tcl $PKG/usr/doc/$PRGNAM-$VERSION/play.tcl
- )
-fi
-
-# todo: java, csharp
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog NEWS COPYING README GPL $PKG/usr/doc/$PRGNAM-$VERSION
-cat src/modules/motion_est/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.motion_est
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-if [ "$php" ]; then
- echo "config etc/php.d/$PRGNAM.ini.new" >> $PKG/install/doinst.sh
-fi
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/mlt/mlt.info b/multimedia/mlt/mlt.info
deleted file mode 100644
index becf041057..0000000000
--- a/multimedia/mlt/mlt.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mlt"
-VERSION="6.16.0"
-HOMEPAGE="https://mltframework.org/"
-DOWNLOAD="https://downloads.sourceforge.net/mlt/mlt-6.16.0.tar.gz"
-MD5SUM="e3872267232aae89f5182fd567be2596"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="ffmpeg libdv libquicktime"
-MAINTAINER="Edward W. Koenig"
-EMAIL="kingbeowulf@gmail.com"
diff --git a/multimedia/mlt/slack-desc b/multimedia/mlt/slack-desc
deleted file mode 100644
index 4ddf41c733..0000000000
--- a/multimedia/mlt/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mlt: mlt (Open source multimedia framework)
-mlt:
-mlt: MLT is an open source multimedia framework, designed and developed
-mlt: for television broadcasting. It provides a toolkit for broadcasters,
-mlt: video editors, media players, transcoders, web streamers and many
-mlt: more types of applications. The functionality of the system is
-mlt: provided via an assortment of ready to use tools, XML authoring
-mlt: components, and an extensible plug-in based API.
-mlt:
-mlt: Homepage: https://mltframework.org/
-mlt: