summaryrefslogtreecommitdiffstats
path: root/multimedia/mediainfo/mediainfo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mediainfo/mediainfo.SlackBuild')
-rw-r--r--multimedia/mediainfo/mediainfo.SlackBuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/multimedia/mediainfo/mediainfo.SlackBuild b/multimedia/mediainfo/mediainfo.SlackBuild
index 410d331fa0..3b8bb417ba 100644
--- a/multimedia/mediainfo/mediainfo.SlackBuild
+++ b/multimedia/mediainfo/mediainfo.SlackBuild
@@ -1,10 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for mediainfo
# Copyright 2010-2012 Binh Nguyen <binhvng@gmail.com>
# Copyright 2012-2017 Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
-# Copyright 2017-2020 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# Copyright 2017-2024 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,15 +24,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=mediainfo
-VERSION=${VERSION:-20.09}
+VERSION=${VERSION:-24.06}
SRCNAM=MediaInfo
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
-# CLI is built by default, GUI is optional
+# CLI is built by default, GUI is autodetected
+# Either can be disabled by passing the variable with "no"
CLI=${CLI:-yes}
-GUI=${GUI:-no}
+if [ -e /usr/bin/wx-config ]; then GUI=${GUI:-yes}; else GUI=${GUI:-no}; fi
# Clear the document variables to make sure it works
CLIDOC=""
@@ -54,7 +58,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -88,9 +96,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patch to force using system libzen and error out if not present
-patch -p1 < $CWD/remove-internal-libzen-support.patch
-
# Make compiling the CLI version optional
if [ "$CLI" == "yes" ]; then
@@ -120,12 +125,12 @@ if [ "$CLI" == "yes" ]; then
CLIDOC=History_CLI.txt
fi
-# Make compiling the GUI optional -- requires wxWidgets/wxPython
+# Make compiling the GUI optional -- requires wxGTK3
if [ "$GUI" == "yes" ]; then
# Error out if missing WxWidgets/wxPython rather than try downloading and compiling it
cd Project/GNU/GUI
- sed -i 's|WxWidgets not yet compiled, try to compile|wxPython not found. Please install first.|' configure.ac
+ sed -i 's|WxWidgets not yet compiled, try to compile|wxGTK3 not found. Please install first.|' configure.ac
sed -i 's|WxBuiltInCompile$|with_wxwidgets="no"|g' configure.ac
./autogen.sh
@@ -171,4 +176,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE