summaryrefslogtreecommitdiffstats
path: root/misc/subsurface/subsurface.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/subsurface/subsurface.SlackBuild')
-rw-r--r--misc/subsurface/subsurface.SlackBuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/misc/subsurface/subsurface.SlackBuild b/misc/subsurface/subsurface.SlackBuild
index c0d02297a3..5aa202fbde 100644
--- a/misc/subsurface/subsurface.SlackBuild
+++ b/misc/subsurface/subsurface.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for subsurface
@@ -22,12 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=subsurface
SRCNAM=Subsurface
VERSION=${VERSION:-4.9.3}
GOOGLEMAPSVER=${MD5LONG:-0.0.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -73,13 +83,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Ugly hack to avoid header collision between grantlee and grantlee-qt5.
-# https://mail.kde.org/pipermail/release-team/2015-August/008911.html
-sed -i 's|#include <grantlee_templates.h>|#include "grantlee_templates_local.h"|' \
- desktop-widgets/templatelayout.h
-sed -e 's|grantlee/|Grantlee5/grantlee/|' \
- /usr/include/Grantlee5/grantlee_templates.h \
- > grantlee_templates_local.h
+sed -i '/^#include <QPainter>$/a #include <QPainterPath>' desktop-widgets/groupedlineedit.cpp
+
+# Fix building against newer versions of libgit2
+patch -p1 < $CWD/libgit2-version.patch
# Fix the location detection of googlemaps
sed -i "s|../install-root|googlemaps-v.${GOOGLEMAPSVER}|" CMakeLists.txt
@@ -160,4 +167,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE