summaryrefslogtreecommitdiffstats
path: root/misc/protobuf3/protobuf3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/protobuf3/protobuf3.SlackBuild')
-rw-r--r--misc/protobuf3/protobuf3.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/misc/protobuf3/protobuf3.SlackBuild b/misc/protobuf3/protobuf3.SlackBuild
index 40c0c6270d..d853990eed 100644
--- a/misc/protobuf3/protobuf3.SlackBuild
+++ b/misc/protobuf3/protobuf3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for protobuf3
-# Copyright 2017-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2017-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=protobuf3
-VERSION=${VERSION:-3.14.0}
+VERSION=${VERSION:-3.15.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -93,12 +93,10 @@ make
make install DESTDIR=$PKG
# Install the python bindings
-cd python ; python setup.py install --root=$PKG ; cd ..
-
-# Add Python3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- cd python ; python3 setup.py install --root=$PKG ; cd ..
-fi
+cd python
+python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true