summaryrefslogtreecommitdiffstats
path: root/misc/protobuf/protobuf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/protobuf/protobuf.SlackBuild')
-rw-r--r--misc/protobuf/protobuf.SlackBuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/misc/protobuf/protobuf.SlackBuild b/misc/protobuf/protobuf.SlackBuild
index 567660ad5b..de3a3fc9bf 100644
--- a/misc/protobuf/protobuf.SlackBuild
+++ b/misc/protobuf/protobuf.SlackBuild
@@ -6,9 +6,11 @@
PRGNAM=protobuf
VERSION=${VERSION:-2.4.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PYTHON=${PYTHON:-yes}
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@@ -55,6 +57,7 @@ CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --disable-static \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -64,6 +67,11 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+# Install the python bindings
+if [ "${PYTHON:-yes}" = "yes" ]; then
+ cd python ; python setup.py install --root=$PKG ; cd ..
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true