summaryrefslogtreecommitdiffstats
path: root/misc/gramps/gramps.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gramps/gramps.SlackBuild')
-rw-r--r--misc/gramps/gramps.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/misc/gramps/gramps.SlackBuild b/misc/gramps/gramps.SlackBuild
index 49bfe2c150..f3d104a1e0 100644
--- a/misc/gramps/gramps.SlackBuild
+++ b/misc/gramps/gramps.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gramps
-# Copyright 2012 Bill Kirkpatrick USA
+# Copyright 2017 Alan Aversa USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gramps
-VERSION=${VERSION:-4.2.4}
+VERSION=${VERSION:-4.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root $PKG
+python3 setup.py install --root=$PKG --resourcepath=/usr/share
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true