summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython4
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/wxPython4')
-rw-r--r--libraries/wxPython4/README24
-rw-r--r--libraries/wxPython4/cython.patch16
-rw-r--r--libraries/wxPython4/wxPython4.SlackBuild28
-rw-r--r--libraries/wxPython4/wxPython4.info8
4 files changed, 50 insertions, 26 deletions
diff --git a/libraries/wxPython4/README b/libraries/wxPython4/README
index aa28a3c0c7..819388e529 100644
--- a/libraries/wxPython4/README
+++ b/libraries/wxPython4/README
@@ -1,17 +1,17 @@
wxPython4 (Crossplatform GUI Toolkit)
-wxPython is a cross-platform GUI toolkit for the Python programming language.
-It allows Python programmers to create programs with a robust, highly
-functional graphical user interface, simply and easily.
+wxPython is a cross-platform GUI toolkit for the Python programming
+language. It allows Python programmers to create programs with a
+robust, highly functional graphical user interface, simply and easily.
-It is implemented as a set of Python extension modules that wrap the GUI
-components of the popular wxWidgets cross platform library, which is written
-in C++.
+It is implemented as a set of Python extension modules that wrap the
+GUI components of the popular wxWidgets cross platform library, which
+is written in C++.
-wxPython is a cross-platform toolkit. This means that the same program will
-run on multiple platforms without modification.
+wxPython is a cross-platform toolkit. This means that the same program
+will run on multiple platforms without modification.
-Currently Supported platforms are Microsoft Windows, Mac OS X and macOS,
-and Linux or other unix-like systems with GTK2 or GTK3 libraries.
-In most cases the native widgets are used on each platform to provide
-a 100% native look and feel for the application.
+Currently Supported platforms are Microsoft Windows, Mac OS X
+and macOS, and Linux or other unix-like systems with GTK2 or GTK3
+libraries. In most cases the native widgets are used on each platform
+to provide a 100% native look and feel for the application.
diff --git a/libraries/wxPython4/cython.patch b/libraries/wxPython4/cython.patch
new file mode 100644
index 0000000000..3e1a2a0377
--- /dev/null
+++ b/libraries/wxPython4/cython.patch
@@ -0,0 +1,16 @@
+Fix compatibility with Cython 3.0.0
+Remove unused import which seems to be removed in Cython 3.
+https://github.com/wxWidgets/Phoenix/issues/2439
+https://github.com/wxWidgets/Phoenix/pull/2441
+https://github.com/wxWidgets/Phoenix/issues/2514
+https://github.com/wxWidgets/Phoenix/commit/aeb557d01e7cd37176ebbf0f1ae6d0b53c115378
+--- wx/svg/_nanosvg.pyx.orig
++++ wx/svg/_nanosvg.pyx
+@@ -42,7 +42,6 @@ for manipulating the SVG shape info in memory.
+
+ import sys
+
+-cimport cython.object
+ from cpython.buffer cimport (
+ Py_buffer, PyObject_CheckBuffer, PyObject_GetBuffer, PyBUF_SIMPLE,
+ PyBuffer_Release)
diff --git a/libraries/wxPython4/wxPython4.SlackBuild b/libraries/wxPython4/wxPython4.SlackBuild
index 10c9e3e037..ea7862534f 100644
--- a/libraries/wxPython4/wxPython4.SlackBuild
+++ b/libraries/wxPython4/wxPython4.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for wxPython4
-# Copyright 2018-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2018-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,15 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Big thanks to Rich Shepard and Christoph Willing for the discussion on LQ
-#
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wxPython4
SRCNAM=wxPython
-VERSION=${VERSION:-4.0.7.post1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-4.2.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -39,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,9 +75,11 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+patch -p0 < $CWD/cython.patch
python3 setup.py install --root=$PKG
@@ -86,7 +94,7 @@ ln -s /usr/share/icons/hicolor/32x32/apps/PySlices.png $PKG/usr/share/pixmaps/Py
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.rst LICENSE.txt docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -95,4 +103,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/wxPython4/wxPython4.info b/libraries/wxPython4/wxPython4.info
index 3e749effc2..7784561d1f 100644
--- a/libraries/wxPython4/wxPython4.info
+++ b/libraries/wxPython4/wxPython4.info
@@ -1,10 +1,10 @@
PRGNAM="wxPython4"
-VERSION="4.0.7.post1"
+VERSION="4.2.1"
HOMEPAGE="https://wxPython.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/53/de/f2a08242d94d34deb5d54240cbd6cd081d1f4032b9439ab1370d27980c67/wxPython-4.0.7.post1.tar.gz"
-MD5SUM="5e8cca787b93b6206e7d219ab2df933c"
+DOWNLOAD="https://files.pythonhosted.org/packages/aa/64/d749e767a8ce7bdc3d533334e03bb1106fc4e4803d16f931fada9007ee13/wxPython-4.2.1.tar.gz"
+MD5SUM="e62c5bd836d2a9dcb6e955509715b157"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="webkit2gtk pathlib2 python3-sip"
+REQUIRES="webkit2gtk python3-pathlib2 python3-attrdict"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"