summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython4/wxPython4.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/wxPython4/wxPython4.SlackBuild')
-rw-r--r--libraries/wxPython4/wxPython4.SlackBuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/libraries/wxPython4/wxPython4.SlackBuild b/libraries/wxPython4/wxPython4.SlackBuild
index 10c9e3e037..ea7862534f 100644
--- a/libraries/wxPython4/wxPython4.SlackBuild
+++ b/libraries/wxPython4/wxPython4.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for wxPython4
-# Copyright 2018-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2018-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,15 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Big thanks to Rich Shepard and Christoph Willing for the discussion on LQ
-#
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wxPython4
SRCNAM=wxPython
-VERSION=${VERSION:-4.0.7.post1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-4.2.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -39,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,9 +75,11 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+patch -p0 < $CWD/cython.patch
python3 setup.py install --root=$PKG
@@ -86,7 +94,7 @@ ln -s /usr/share/icons/hicolor/32x32/apps/PySlices.png $PKG/usr/share/pixmaps/Py
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.rst LICENSE.txt docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -95,4 +103,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE