summaryrefslogtreecommitdiffstats
path: root/libraries/tclsoap/patches
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/tclsoap/patches')
-rw-r--r--libraries/tclsoap/patches/Makefile.in.patch12
-rw-r--r--libraries/tclsoap/patches/SOAP.tcl.patch22
-rw-r--r--libraries/tclsoap/patches/pkgIndex.tcl.patch14
-rw-r--r--libraries/tclsoap/patches/xpath.tcl.patch17
4 files changed, 65 insertions, 0 deletions
diff --git a/libraries/tclsoap/patches/Makefile.in.patch b/libraries/tclsoap/patches/Makefile.in.patch
new file mode 100644
index 0000000000..88f64785f2
--- /dev/null
+++ b/libraries/tclsoap/patches/Makefile.in.patch
@@ -0,0 +1,12 @@
+# adapted from FreeBSD ports (author's email: dereckson@gmail.com)
+--- Makefile.in
++++ Makefile.in
+@@ -56,7 +56,7 @@ docdir = @docdir@
+
+ DESTDIR =
+
+-pkglibdir = $(libdir)/@PACKAGE@@VERSION@
++pkglibdir = $(libdir)/@PACKAGE@
+
+ top_builddir = .
+
diff --git a/libraries/tclsoap/patches/SOAP.tcl.patch b/libraries/tclsoap/patches/SOAP.tcl.patch
new file mode 100644
index 0000000000..1b7804bda1
--- /dev/null
+++ b/libraries/tclsoap/patches/SOAP.tcl.patch
@@ -0,0 +1,22 @@
+# adapted from FreeBSD ports (author's email: dereckson@gmail.com)
+--- SOAP.tcl
++++ SOAP.tcl
+@@ -22,12 +22,11 @@ package require rpcvar; # TclSOAP
+
+ namespace eval ::SOAP {variable domVersion}
+ if {[catch {package require SOAP::dom 1.0} ::SOAP::domVersion]} {
+- if { [catch {package require dom 2.0} ::SOAP::domVersion]} {
+- if { [catch {package require dom 1.6} ::SOAP::domVersion]} {
+- error "require dom package greater than 1.6"
+- }
+- package require SOAP::xpath; # TclSOAP
++ if {[catch {package require dom} ::SOAP::domVersion] || [package vcompare $::SOAP::domVersion 1.6] < 0} {
++ error "require dom package greater than 1.6"
+ }
++ package require SOAP::xpath; # TclSOAP
++
+ proc ::SOAP::createDocument {name} {
+ set doc [dom::DOMImplementation create]
+ return [dom::document createElement $doc $name]
+
+
diff --git a/libraries/tclsoap/patches/pkgIndex.tcl.patch b/libraries/tclsoap/patches/pkgIndex.tcl.patch
new file mode 100644
index 0000000000..71e2d674ed
--- /dev/null
+++ b/libraries/tclsoap/patches/pkgIndex.tcl.patch
@@ -0,0 +1,14 @@
+# adapted from FreeBSD ports (author's email: dereckson@gmail.com)
+--- pkgIndex.tcl
++++ pkgIndex.tcl
+@@ -11,8 +11,7 @@
+ package ifneeded SOAP 1.6.7 [list source [file join $dir SOAP.tcl]]
+ package ifneeded SOAP::CGI 1.0 [list source [file join $dir SOAP-CGI.tcl]]
+ package ifneeded SOAP::Domain 1.4 [list source [file join $dir SOAP-domain.tcl]]
+-package ifneeded SOAP::Service 0.4 [list source [file join $dir SOAP-service.tcl]]
+-package ifneeded SOAP::Utils 1.0 [list source [file join $dir utils.tcl]]
++package ifneeded SOAP::Utils 1.0.1 [list source [file join $dir utils.tcl]]
+ package ifneeded SOAP::ftp 1.0 [list source [file join $dir ftp.tcl]]
+ package ifneeded SOAP::http 1.0 [list source [file join $dir http.tcl]]
+ package ifneeded SOAP::https 1.0 [list source [file join $dir https.tcl]]
+
diff --git a/libraries/tclsoap/patches/xpath.tcl.patch b/libraries/tclsoap/patches/xpath.tcl.patch
new file mode 100644
index 0000000000..5aacac3c3b
--- /dev/null
+++ b/libraries/tclsoap/patches/xpath.tcl.patch
@@ -0,0 +1,17 @@
+# adapted from FreeBSD ports (author's email: dereckson@gmail.com)
+--- xpath.tcl
++++ xpath.tcl
+@@ -14,10 +14,9 @@
+ # for more details.
+ # -------------------------------------------------------------------------
+
+-if { [catch {package require dom 2.0}] } {
+- if { [catch {package require dom 1.6}] } {
++namespace eval ::SOAP {variable domVersion}
++if { [catch {package require dom} ::SOAP::domVersion] || [package vcompare $::SOAP::domVersion 1.6] < 0} {
+ error "require dom package greater than 1.6"
+- }
+ }
+
+ namespace eval SOAP::xpath {
+