summaryrefslogtreecommitdiffstats
path: root/libraries/podofo/podofo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/podofo/podofo.SlackBuild')
-rw-r--r--libraries/podofo/podofo.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/libraries/podofo/podofo.SlackBuild b/libraries/podofo/podofo.SlackBuild
index fbc03df177..00c65076c7 100644
--- a/libraries/podofo/podofo.SlackBuild
+++ b/libraries/podofo/podofo.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for podofo
-# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=podofo
VERSION=${VERSION:-0.9.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -34,14 +34,14 @@ OUTPUT=${OUTPUT:-/tmp}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX="FALSE"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -71,8 +71,8 @@ find -L . \
# Fix mandir directory.
sed -i 's|share/man|man|' CMakeLists.txt
-# Don't compile unit tests on x86 with cppunit.
-sed -i 's|PODOFO_HAVE_CPPUNIT.*|PODOFO_HAVE_CPPUNIT OFF)|' CMakeLists.txt
+# Fix building podofo on x86 with cppunit.
+patch -p1 < $CWD/podofo-0.9.4_build.patch
mkdir build
cd build