summaryrefslogtreecommitdiffstats
path: root/libraries/physfs/physfs.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/physfs/physfs.SlackBuild')
-rw-r--r--libraries/physfs/physfs.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/libraries/physfs/physfs.SlackBuild b/libraries/physfs/physfs.SlackBuild
index 5ee10e504f..ed5994a8ef 100644
--- a/libraries/physfs/physfs.SlackBuild
+++ b/libraries/physfs/physfs.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=physfs
VERSION=2.0.2
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -65,6 +65,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
+# while we cut away -Werror to make gcc-4.6 happy, we turn off debug too
+sed -i "s|-g -pipe -Werror|-pipe|" CMakeLists.txt
+
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \