summaryrefslogtreecommitdiffstats
path: root/libraries/libxlsxwriter
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libxlsxwriter')
-rw-r--r--libraries/libxlsxwriter/README9
-rw-r--r--libraries/libxlsxwriter/cmake_version_check.patch16
-rw-r--r--libraries/libxlsxwriter/libxlsxwriter.SlackBuild35
-rw-r--r--libraries/libxlsxwriter/libxlsxwriter.info8
4 files changed, 48 insertions, 20 deletions
diff --git a/libraries/libxlsxwriter/README b/libraries/libxlsxwriter/README
index 45567e168f..aa0f51b3c0 100644
--- a/libraries/libxlsxwriter/README
+++ b/libraries/libxlsxwriter/README
@@ -1,8 +1,8 @@
A C library for creating Excel XLSX files
-Libxlsxwriter is a C library that can be used to write text, numbers, formulas
-and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file. It supports
-features such as:
+Libxlsxwriter is a C library that can be used to write text, numbers,
+formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX
+file. It supports features such as:
* 100% compatible Excel XLSX files.
* Full Excel formatting.
@@ -16,7 +16,8 @@ features such as:
* Source code available on GitHub.
* FreeBSD License.
* ANSI C.
-* Works with GCC, Clang, Xcode, MSVC 2015, ICC, TCC, MinGW, MingGW-w64/32.
+* Works with GCC, Clang, Xcode, MSVC 2015, ICC, TCC, MinGW,
+ MingGW-w64/32.
* Works on Linux, FreeBSD, OpenBSD, OS X, iOS and Windows. Also works on
MSYS/MSYS2 and Cygwin.
* Compiles for 32 and 64 bit.
diff --git a/libraries/libxlsxwriter/cmake_version_check.patch b/libraries/libxlsxwriter/cmake_version_check.patch
new file mode 100644
index 0000000000..c997d6d33c
--- /dev/null
+++ b/libraries/libxlsxwriter/cmake_version_check.patch
@@ -0,0 +1,16 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2019-12-16 21:07:03.000000000 +0000
++++ b/CMakeLists.txt 2019-12-18 17:18:01.270919658 +0000
+@@ -99,9 +99,9 @@
+ # The use of the word ZLIB_ROOT should still work prior to "3.12.0",
+ # just it's been generalized for all packages now. Just set the policy
+ # to new, so we use it, and it will be used prior to 3.12 anyway.
+-if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.12")
+- cmake_policy(SET CMP0074 NEW)
+-endif()
++#if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.12")
++# cmake_policy(SET CMP0074 NEW)
++#endif()
+
+ # OPTIONS
+ # -------
diff --git a/libraries/libxlsxwriter/libxlsxwriter.SlackBuild b/libraries/libxlsxwriter/libxlsxwriter.SlackBuild
index 3621658f27..9174762d43 100644
--- a/libraries/libxlsxwriter/libxlsxwriter.SlackBuild
+++ b/libraries/libxlsxwriter/libxlsxwriter.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for libxlsxwriter
-# Copyright 2018 David Woodfall <dave@dawoodfall.net>
+# Copyright 2018 David Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,10 +21,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220420 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix doc permissions.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=libxlsxwriter
-VERSION=${VERSION:-0.8.7}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -34,7 +40,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -64,9 +74,11 @@ cd $PRGNAM-RELEASE_$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+patch -p1 --verbose <$CWD/cmake_version_check.patch
mkdir -p build
cd build
@@ -74,14 +86,13 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
+chmod 644 docs/images/*.png # 20220420 bkw: wtf, people?
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
docs *.txt \
@@ -92,4 +103,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libxlsxwriter/libxlsxwriter.info b/libraries/libxlsxwriter/libxlsxwriter.info
index 3c5ce10168..e2616ea950 100644
--- a/libraries/libxlsxwriter/libxlsxwriter.info
+++ b/libraries/libxlsxwriter/libxlsxwriter.info
@@ -1,10 +1,10 @@
PRGNAM="libxlsxwriter"
-VERSION="0.8.7"
+VERSION="1.0.2"
HOMEPAGE="https://libxlsxwriter.github.io/"
-DOWNLOAD="https://github.com/jmcnamara/libxlsxwriter/archive/RELEASE_0.8.7/libxlsxwriter-RELEASE_0.8.7.tar.gz"
-MD5SUM="fd994fc6a15d6e0545288c23ac588ccd"
+DOWNLOAD="https://github.com/jmcnamara/libxlsxwriter/archive/RELEASE_1.0.2/libxlsxwriter-RELEASE_1.0.2.tar.gz"
+MD5SUM="82b004c9a3b1b4af8313dfa8ed8ea094"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Dave Woodfall"
+MAINTAINER="D Woodfall"
EMAIL="dave@slackbuilds.org"