summaryrefslogtreecommitdiffstats
path: root/libraries/libvirt-python
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libvirt-python')
-rw-r--r--libraries/libvirt-python/libvirt-python.SlackBuild8
-rw-r--r--libraries/libvirt-python/libvirt-python.info8
2 files changed, 8 insertions, 8 deletions
diff --git a/libraries/libvirt-python/libvirt-python.SlackBuild b/libraries/libvirt-python/libvirt-python.SlackBuild
index 9688b5afe4..c6684a1cf2 100644
--- a/libraries/libvirt-python/libvirt-python.SlackBuild
+++ b/libraries/libvirt-python/libvirt-python.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for libvirt-python
-# Copyright 2013-2018 Robby Workman, Tuscaloosa, Alabama, USA
+# Copyright 2013-2021 Robby Workman, Tuscaloosa, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libvirt-python
-VERSION=${VERSION:-4.5.0}
+VERSION=${VERSION:-7.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -66,14 +66,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING* ChangeLog NEWS PKG-INFO README \
+ AUTHORS COPYING* ChangeLog PKG-INFO README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/libvirt-python/libvirt-python.info b/libraries/libvirt-python/libvirt-python.info
index 0670df4073..05bcff5b5e 100644
--- a/libraries/libvirt-python/libvirt-python.info
+++ b/libraries/libvirt-python/libvirt-python.info
@@ -1,8 +1,8 @@
PRGNAM="libvirt-python"
-VERSION="4.5.0"
-HOMEPAGE="http://libvirt.org"
-DOWNLOAD="https://libvirt.org/sources/python/libvirt-python-4.5.0.tar.gz"
-MD5SUM="0c1b66a8878d6436b036565060707f73"
+VERSION="7.2.0"
+HOMEPAGE="https://libvirt.org"
+DOWNLOAD="https://libvirt.org/sources/python/libvirt-python-7.2.0.tar.gz"
+MD5SUM="19bf22414a43d358581b9259b52047a7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libvirt"