summaryrefslogtreecommitdiffstats
path: root/libraries/libvirt-python/libvirt-python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libvirt-python/libvirt-python.SlackBuild')
-rw-r--r--libraries/libvirt-python/libvirt-python.SlackBuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/libraries/libvirt-python/libvirt-python.SlackBuild b/libraries/libvirt-python/libvirt-python.SlackBuild
index 9688b5afe4..8ecccb3148 100644
--- a/libraries/libvirt-python/libvirt-python.SlackBuild
+++ b/libraries/libvirt-python/libvirt-python.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libvirt-python
-VERSION=${VERSION:-4.5.0}
+VERSION=${VERSION:-5.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -66,7 +66,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true