summaryrefslogtreecommitdiffstats
path: root/libraries/libtorrent/libtorrent.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libtorrent/libtorrent.SlackBuild')
-rw-r--r--libraries/libtorrent/libtorrent.SlackBuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/libraries/libtorrent/libtorrent.SlackBuild b/libraries/libtorrent/libtorrent.SlackBuild
index feb2231046..c1da5e7339 100644
--- a/libraries/libtorrent/libtorrent.SlackBuild
+++ b/libraries/libtorrent/libtorrent.SlackBuild
@@ -5,13 +5,13 @@
# Updated by Andrew Brouwers, abrouwers@gmail.com
PRGNAM=libtorrent
-VERSION=${VERSION:-0.13.6}
+VERSION=${VERSION:-0.13.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,8 +22,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -51,6 +51,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i '/AM_PATH_CPPUNIT/d' configure.ac
+patch -p1 < $CWD/libtorrent-openssl-1.1.patch
+./autogen.sh
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -59,6 +63,7 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--with-posix-fallocate \
+ --disable-debug \
--build=$ARCH-slackware-linux
make