summaryrefslogtreecommitdiffstats
path: root/libraries/genshi/genshi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/genshi/genshi.SlackBuild')
-rw-r--r--libraries/genshi/genshi.SlackBuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/libraries/genshi/genshi.SlackBuild b/libraries/genshi/genshi.SlackBuild
index 2b91259eeb..d35ffc300f 100644
--- a/libraries/genshi/genshi.SlackBuild
+++ b/libraries/genshi/genshi.SlackBuild
@@ -3,11 +3,12 @@
# Slackware build script for Genshi
# Written by Eugene Suter <easuter at gmail.com>
# Maintained by James Geboski <jgeboski@gmail.com>
+# now by Matteo Bernardini <ponce@slackbuilds.org>
-PRGNAM="genshi"
-SRCNAM="Genshi"
-VERSION=${VERSION:-0.6}
-BUILD=${BUILD:-2}
+PRGNAM=genshi
+SRCNAM=Genshi
+VERSION=${VERSION:-0.7}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -47,10 +48,10 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -63,4 +64,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-