summaryrefslogtreecommitdiffstats
path: root/libraries/batinfo/batinfo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/batinfo/batinfo.SlackBuild')
-rw-r--r--libraries/batinfo/batinfo.SlackBuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/libraries/batinfo/batinfo.SlackBuild b/libraries/batinfo/batinfo.SlackBuild
index 3105466b7d..0c0fcc6aab 100644
--- a/libraries/batinfo/batinfo.SlackBuild
+++ b/libraries/batinfo/batinfo.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Slackware build script for Batinfo
+# Slackware build script for batinfo
# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
# All rights reserved.
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=batinfo
-VERSION=${VERSION:-2.0}
+VERSION=${VERSION:-0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,8 +47,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The upstream tarball will be named differently, depending on the file being
-# downloaded manually (web browser) or with wget.
+# The upstream tarball will be named differently, depending on
+# the file being downloaded manually (web browser) or with wget.
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvzf $CWD/v$VERSION.tar.gz
else
@@ -63,9 +63,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGUSR=$PKG/usr
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -73,13 +70,17 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGSHR=$PKG/usr/share
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Install documentation.
mkdir -p $PRGDOC
-mv $PRGUSR/share/doc/$PRGNAM/* $PRGDOC/
-rm -rf $PRGUSR/share
+mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+rm -rf $PRGSHR
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc