summaryrefslogtreecommitdiffstats
path: root/libraries/VTK
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/VTK')
-rw-r--r--libraries/VTK/VTK.SlackBuild14
-rw-r--r--libraries/VTK/patch-gcc10.diff40
-rw-r--r--libraries/VTK/vtk-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch18
3 files changed, 72 insertions, 0 deletions
diff --git a/libraries/VTK/VTK.SlackBuild b/libraries/VTK/VTK.SlackBuild
index ae29a67c07..7fa81dd1b8 100644
--- a/libraries/VTK/VTK.SlackBuild
+++ b/libraries/VTK/VTK.SlackBuild
@@ -96,6 +96,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Build with libfreetype-2.10.3 and higher patch courtesy of
+# https://bugs.archlinux.org/task/68291#comments
+# also upstream at https://gitlab.kitware.com/vtk/vtk/-/issues/18033
+patch -p1 < $CWD/vtk-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch
+
+sed -i '/include <QTextStream>/a #include <QPainterPath>' \
+ Rendering/Qt/vtkQtLabelRenderStrategy.cxx \
+ Rendering/Qt/vtkQtStringToImage.cxx
+
if pkg-config --exists proj ; then
proj="-DVTK_USE_SYSTEM_LIBPROJ:BOOL=ON"
# proj6 patch courtesy of
@@ -105,6 +114,11 @@ else
proj=""
fi
+# https://github.com/archlinux/svntogit-community/blob/packages/vtk/trunk/PKGBUILD
+( cd ThirdParty/exodusII/vtkexodusII
+ patch -p1 < $CWD/patch-gcc10.diff )
+sed -i 's|REGEX MATCH \"\[3-9\]|REGEX MATCH \"[1-9][0-9]|' CMake/VTKGenerateExportHeader.cmake
+
mkdir -p build
cd build
cmake \
diff --git a/libraries/VTK/patch-gcc10.diff b/libraries/VTK/patch-gcc10.diff
new file mode 100644
index 0000000000..507c8a7a64
--- /dev/null
+++ b/libraries/VTK/patch-gcc10.diff
@@ -0,0 +1,40 @@
+From a9079bdccbb2165583d6773a5ed848427e2a38a8 Mon Sep 17 00:00:00 2001
+From: Seacas Upstream <kwrobot@kitware.com>
+Date: Tue, 28 Jan 2020 09:13:38 -0500
+Subject: [PATCH] exodusII 2020-01-28 (d97eb08d)
+
+Code extracted from:
+
+ https://gitlab.kitware.com/third-party/seacas.git
+
+at commit d97eb08d79e87c82facfae39bc75deb60c0a2d83 (for/vtk-20200128-7.24f-v2019-12-18).
+---
+ src/ex_create_par.c | 2 +-
+ src/ex_open_par.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ex_create_par.c b/src/ex_create_par.c
+index 8d5d6734f0..ef439618da 100644
+--- a/src/ex_create_par.c
++++ b/src/ex_create_par.c
+@@ -216,5 +216,5 @@ int ex_create_par_int(const char *path, int cmode, int *comp_ws, int *io_ws, MPI
+ * Prevent warning in some versions of ranlib(1) because the object
+ * file has no symbols.
+ */
+-const char exodus_unused_symbol_dummy_1;
++const char exodus_unused_symbol_dummy_ex_create_par;
+ #endif
+diff --git a/src/ex_open_par.c b/src/ex_open_par.c
+index b2faa22c29..9df4818767 100644
+--- a/src/ex_open_par.c
++++ b/src/ex_open_par.c
+@@ -459,5 +459,5 @@ int ex_open_par_int(const char *path, int mode, int *comp_ws, int *io_ws, float
+ * Prevent warning in some versions of ranlib(1) because the object
+ * file has no symbols.
+ */
+-const char exodus_unused_symbol_dummy_1;
++const char exodus_unused_symbol_dummy_ex_open_par;
+ #endif
+--
+GitLab
+
diff --git a/libraries/VTK/vtk-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch b/libraries/VTK/vtk-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch
new file mode 100644
index 0000000000..b467487350
--- /dev/null
+++ b/libraries/VTK/vtk-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch
@@ -0,0 +1,18 @@
+--- VTK-8.2.0/ThirdParty/freetype/vtk_freetype.h.in.orig 2019-01-30 18:15:13.000000000 +0100
++++ VTK-8.2.0/ThirdParty/freetype/vtk_freetype.h.in 2020-10-17 00:03:32.730820908 +0200
+@@ -20,6 +20,15 @@
+
+ #ifdef VTK_USE_SYSTEM_FREETYPE
+ # include <ft2build.h>
++/* FT_CALLBACK_DEF no longer exported since freetype-2.10.3 */
++/* has been moved to <freetype/internal/compiler-macros.h> */
++# ifndef FT_CALLBACK_DEF
++# ifdef __cplusplus
++# define FT_CALLBACK_DEF( x ) extern "C" x
++# else
++# define FT_CALLBACK_DEF( x ) static x
++# endif
++# endif /* FT_CALLBACK_DEF */
+ #else
+ # include <vtkfreetype/include/ft2build.h>
+ #endif