summaryrefslogtreecommitdiffstats
path: root/libraries/SimGear
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/SimGear')
-rw-r--r--libraries/SimGear/0004-fix-for-boost-1.69.patch24
-rw-r--r--libraries/SimGear/SimGear.SlackBuild7
2 files changed, 31 insertions, 0 deletions
diff --git a/libraries/SimGear/0004-fix-for-boost-1.69.patch b/libraries/SimGear/0004-fix-for-boost-1.69.patch
new file mode 100644
index 0000000000..2372c8c58a
--- /dev/null
+++ b/libraries/SimGear/0004-fix-for-boost-1.69.patch
@@ -0,0 +1,24 @@
+From c1ac1fb93dace81b2a60f9d1f5d6d20298c8b9bb Mon Sep 17 00:00:00 2001
+From: Fabrice Bellet <fabrice@bellet.info>
+Date: Fri, 1 Feb 2019 09:29:40 +0100
+Subject: [PATCH] fix for boost 1.69
+
+---
+ simgear/nasal/cppbind/NasalHash.hxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/simgear/nasal/cppbind/NasalHash.hxx b/simgear/nasal/cppbind/NasalHash.hxx
+index aac672fd..2ee7d044 100644
+--- a/simgear/nasal/cppbind/NasalHash.hxx
++++ b/simgear/nasal/cppbind/NasalHash.hxx
+@@ -23,6 +23,7 @@
+ #include "to_nasal.hxx"
+
+ #include <simgear/structure/map.hxx>
++#include <boost/core/enable_if.hpp>
+ #include <boost/iterator/iterator_facade.hpp>
+
+ namespace nasal
+--
+2.20.1
+
diff --git a/libraries/SimGear/SimGear.SlackBuild b/libraries/SimGear/SimGear.SlackBuild
index f9e030a607..1425d43902 100644
--- a/libraries/SimGear/SimGear.SlackBuild
+++ b/libraries/SimGear/SimGear.SlackBuild
@@ -70,6 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/0004-fix-for-boost-1.69.patch
+
mkdir -p build
cd build
cmake \
@@ -80,6 +82,11 @@ cd build
-DSYSTEM_EXPAT=ON \
-DENABLE_TESTS=OFF \
-DCMAKE_BUILD_TYPE=Release ..
+
+ # various CMakeLists.txt files must be revised for the newer cmake...
+ mv config.h ../3rdparty/udns/
+ mv simgear/simgear_config.h simgear/version.h ../simgear/
+
make
make install DESTDIR=$PKG
cd ..