summaryrefslogtreecommitdiffstats
path: root/libraries/SDL2
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/SDL2')
-rw-r--r--libraries/SDL2/README9
-rw-r--r--libraries/SDL2/SDL2.SlackBuild99
-rw-r--r--libraries/SDL2/SDL2.info10
-rw-r--r--libraries/SDL2/slack-desc19
4 files changed, 0 insertions, 137 deletions
diff --git a/libraries/SDL2/README b/libraries/SDL2/README
deleted file mode 100644
index 7fa6c9b740..0000000000
--- a/libraries/SDL2/README
+++ /dev/null
@@ -1,9 +0,0 @@
-SDL2 (Simple DirectMedia Layer Version 2)
-
-Simple DirectMedia Layer is a cross-platform development library designed to
-provide low-level access to audio, keyboard, mouse, joystick, and graphics
-hardware via OpenGL.
-
-SDL is written in C and works natively with C++.
-
-This is safe to install alongside Slackware's SDL libraries.
diff --git a/libraries/SDL2/SDL2.SlackBuild b/libraries/SDL2/SDL2.SlackBuild
deleted file mode 100644
index 9172772783..0000000000
--- a/libraries/SDL2/SDL2.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for SDL2
-
-# Copyright 2013 Dugan Chen Canada
-# Copyright 2020 Isaac Yu
-# Copyright 2020 B. Watson
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20200415 bkw:
-# - take over maintenance
-# - don't install static libSDL2.a
-# - don't copy CMakeLists.txt to doc dir (it's not documentation)
-# - don't copy useless INSTALL.txt to doc dir
-# - BUILD=2
-
-PRGNAM=SDL2
-VERSION=${VERSION:-2.0.12}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DBUILD_SHARED_LIBS=ON \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install/strip DESTDIR=$PKG
-cd ..
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-rm -f INSTALL.txt CMakeLists.txt # don't copy these to doc dir
-cp -a *.txt docs/*.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/SDL2/SDL2.info b/libraries/SDL2/SDL2.info
deleted file mode 100644
index a245b7b23a..0000000000
--- a/libraries/SDL2/SDL2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="SDL2"
-VERSION="2.0.12"
-HOMEPAGE="https://libsdl.org"
-DOWNLOAD="https://www.libsdl.org/release/SDL2-2.0.12.tar.gz"
-MD5SUM="783b6f2df8ff02b19bb5ce492b99c8ff"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/libraries/SDL2/slack-desc b/libraries/SDL2/slack-desc
deleted file mode 100644
index fa23090367..0000000000
--- a/libraries/SDL2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-SDL2: SDL2 (Simple DirectMedia Layer Version 2)
-SDL2:
-SDL2: Simple DirectMedia Layer is a cross-platform development library
-SDL2: designed to provide low-level access to audio, keyboard, mouse,
-SDL2: joystick, and graphics hardware ia via OpenGL.
-SDL2:
-SDL2: SDL is written in C and works natively with C++.
-SDL2:
-SDL2: https://libsdl.org
-SDL2:
-SDL2: