summaryrefslogtreecommitdiffstats
path: root/graphics/shaderc/shaderc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/shaderc/shaderc.SlackBuild')
-rw-r--r--graphics/shaderc/shaderc.SlackBuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/shaderc/shaderc.SlackBuild b/graphics/shaderc/shaderc.SlackBuild
index bf2c19eafb..22b721cfbb 100644
--- a/graphics/shaderc/shaderc.SlackBuild
+++ b/graphics/shaderc/shaderc.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=shaderc
VERSION=${VERSION:-2019.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -76,9 +76,6 @@ sed -i '/build-version/d' glslc/CMakeLists.txt
glslang_version="$(glslangValidator -v | grep 'Glslang Version')"
# Create build-version.inc since git versioning is disabled.
-# There does not seem to be any good way to get the glslang version
-# so use the latest version from their github repo.
-# https://github.com/KhronosGroup/glslang
# This is displayed with 'glslc --version'.
cat > glslc/src/build-version.inc <<EOF
"shaderc $VERSION\\n"
@@ -90,6 +87,11 @@ EOF
# https://github.com/google/shaderc/pull/463
patch -p1 < $CWD/fix-glslang-link-order.patch
+# Force Glslang to support HLSL in its interface
+# https://github.com/google/shaderc/commit/ec4ea59c6d523ee563611651e6a15b1c31ffcd2e
+# https://github.com/google/shaderc/pull/784
+patch -p1 < $CWD/fix-glslang-build.patch
+
mkdir -p build
cd build
cmake \