summaryrefslogtreecommitdiffstats
path: root/graphics/mirage
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mirage')
-rw-r--r--graphics/mirage/mirage.SlackBuild20
-rw-r--r--graphics/mirage/mirage.info8
2 files changed, 19 insertions, 9 deletions
diff --git a/graphics/mirage/mirage.SlackBuild b/graphics/mirage/mirage.SlackBuild
index f96e5a2616..2515c4bd24 100644
--- a/graphics/mirage/mirage.SlackBuild
+++ b/graphics/mirage/mirage.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for Mirage
@@ -27,10 +27,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=mirage
-VERSION=${VERSION:-1.0_pre2}
+VERSION=${VERSION:-0.11.2}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,7 +43,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -60,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root $PKG
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -76,4 +86,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/mirage/mirage.info b/graphics/mirage/mirage.info
index 69ec3409df..3a4eb10aa2 100644
--- a/graphics/mirage/mirage.info
+++ b/graphics/mirage/mirage.info
@@ -1,8 +1,8 @@
PRGNAM="mirage"
-VERSION="1.0_pre2"
-HOMEPAGE="https://sourceforge.net/projects/mirageiv.berlios/"
-DOWNLOAD="https://sourceforge.net/projects/mirageiv.berlios/files/mirage-1.0_pre2.tar.bz2"
-MD5SUM="3a0cdb4efd445f85bc29a1ab7ff8a579"
+VERSION="0.11.2"
+HOMEPAGE="https://gitlab.com/thomasross/mirage/"
+DOWNLOAD="https://gitlab.com/thomasross/mirage/-/archive/0.11.2/mirage-0.11.2.tar.bz2"
+MD5SUM="6105a1e98130a3926fb4c063a4421f63"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""