summaryrefslogtreecommitdiffstats
path: root/graphics/dblatex/dblatex.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dblatex/dblatex.SlackBuild')
-rw-r--r--graphics/dblatex/dblatex.SlackBuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/graphics/dblatex/dblatex.SlackBuild b/graphics/dblatex/dblatex.SlackBuild
index d3a96042c0..a178b128d4 100644
--- a/graphics/dblatex/dblatex.SlackBuild
+++ b/graphics/dblatex/dblatex.SlackBuild
@@ -7,8 +7,9 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dblatex
-VERSION=${VERSION:-0.3.10}
-BUILD=${BUILD:-2}
+SRCNAM=dblatex3
+VERSION=${VERSION:-0.3.12}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -20,9 +21,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,9 +49,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.*z?
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -61,18 +59,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix build
-patch -p0 -i $CWD/dblatex-0.3.4-build-fix.patch
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-# latex in slackware 14.2 doesn't have this package
-unzip "$CWD/bookmark.tds.zip"
-cp -pav "./tex/latex/bookmark/" "./latex/"
-
-python setup.py build
-python setup.py install --root=$PKG
-
-mv $PKG/usr/share/man $PKG/usr/
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done