summaryrefslogtreecommitdiffstats
path: root/gis/pytrainer/pytrainer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/pytrainer/pytrainer.SlackBuild')
-rw-r--r--gis/pytrainer/pytrainer.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/gis/pytrainer/pytrainer.SlackBuild b/gis/pytrainer/pytrainer.SlackBuild
index bba1b09a24..7165cf0033 100644
--- a/gis/pytrainer/pytrainer.SlackBuild
+++ b/gis/pytrainer/pytrainer.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Pytrainer
-# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2024 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pytrainer
-VERSION=${VERSION:-2.0.2}
+VERSION=${VERSION:-2.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,16 +38,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="COPYING INSTALL PLUGINS.README README.md"
@@ -63,7 +60,7 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION