summaryrefslogtreecommitdiffstats
path: root/gis/geographiclib-python/geographiclib-python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/geographiclib-python/geographiclib-python.SlackBuild')
-rw-r--r--gis/geographiclib-python/geographiclib-python.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/gis/geographiclib-python/geographiclib-python.SlackBuild b/gis/geographiclib-python/geographiclib-python.SlackBuild
index 09a90d09fe..ad5c8abcad 100644
--- a/gis/geographiclib-python/geographiclib-python.SlackBuild
+++ b/gis/geographiclib-python/geographiclib-python.SlackBuild
@@ -2,7 +2,7 @@
#
# SlackBuild for geographiclib-python
#
-# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2016-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -24,7 +24,7 @@
SRCNAM=geographiclib
PRGNAM=$SRCNAM-python
VERSION=${VERSION:-1.49}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,10 +71,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \