summaryrefslogtreecommitdiffstats
path: root/gis/geographiclib-python/geographiclib-python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/geographiclib-python/geographiclib-python.SlackBuild')
-rw-r--r--gis/geographiclib-python/geographiclib-python.SlackBuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/gis/geographiclib-python/geographiclib-python.SlackBuild b/gis/geographiclib-python/geographiclib-python.SlackBuild
index 73fa00c267..1f725b3a76 100644
--- a/gis/geographiclib-python/geographiclib-python.SlackBuild
+++ b/gis/geographiclib-python/geographiclib-python.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
#
# SlackBuild for geographiclib-python
#
-# Copyright 2016-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2016-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -21,11 +21,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM=geographiclib
-PRGNAM=$SRCNAM-python
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=geographiclib-python
VERSION=${VERSION:-1.50}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=geographiclib
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,7 +82,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -84,4 +94,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE