summaryrefslogtreecommitdiffstats
path: root/games/stratagus/stratagus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/stratagus/stratagus.SlackBuild')
-rw-r--r--games/stratagus/stratagus.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/stratagus/stratagus.SlackBuild b/games/stratagus/stratagus.SlackBuild
index d7aaac7302..99b74a19c2 100644
--- a/games/stratagus/stratagus.SlackBuild
+++ b/games/stratagus/stratagus.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for stratagus
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
@@ -43,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -85,6 +82,9 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# share/doc/$PRGNAM, so:
sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," CMakeLists.txt
+# 20211119 bkw: fix compile with -current's gcc.
+sed -i 's,"_C_," _C_,' src/ai/ai_plan.cpp src/stratagus/script.cpp
+
mkdir -p build
cd build
cmake \