summaryrefslogtreecommitdiffstats
path: root/games/retux/retux.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/retux/retux.SlackBuild')
-rw-r--r--games/retux/retux.SlackBuild43
1 files changed, 29 insertions, 14 deletions
diff --git a/games/retux/retux.SlackBuild b/games/retux/retux.SlackBuild
index 7eb0e6b2e5..f6da7d4892 100644
--- a/games/retux/retux.SlackBuild
+++ b/games/retux/retux.SlackBuild
@@ -2,14 +2,18 @@
# Slackware build script for retux
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-# Note: This would depend on six and sge-pygame, except upstream kindly
-# shipped his own bundled copies. The game looks for modules in its own
-# directory first, so any system-wide installs of six and sge-pygame
-# won't cause problems.
+# 20230713 bkw: update for v1.6.2.
+
+# 20211229 bkw:
+# - updated for v1.6.1.
+# - s/python/python3/.
+# - new-style icons.
+# - pathlib doesn't seem to be required any longer.
+# - new dep: python3-sge.
# 20200206 bkw: add missing pygame dep to REQUIRES.
@@ -19,16 +23,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=retux
-VERSION=${VERSION:-1.3.5}
+VERSION=${VERSION:-1.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -46,7 +47,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $DIRNAME
-tar xvf $CWD/$DIRNAME.tar.gz
+unzip $CWD/$DIRNAME.zip
cd $DIRNAME
# upstream perms a bit wonky, force them:
@@ -58,12 +59,18 @@ chmod 755 *.py
# we don't need these, they take up 12MB in the package and are never used.
find . -name sources -print0 | xargs -0 rm -rf
+# don't use setup.py, it's for building a 'frozen' executable.
+# in fact we don't need any .py file other than retux.py.
+mv $PRGNAM.py $PRGNAM.py.keep
+rm -f *.py requirements.txt
+mv $PRGNAM.py.keep $PRGNAM.py
+
# allow launching via symlink. without this, it can't find its data files.
sed -i '/^DATA/i__file__ = os.path.realpath(__file__)' $PRGNAM.py
-# there's no setup.py to do this for us. it's not 100% necessary but does
+# setup.py doesn't do this for us. it's not 100% necessary but does
# speed things up ever so slightly at runtime:
-python -m compileall .
+python3 -m compileall .
mkdir -p \
$PKG/usr/share/games/$PRGNAM \
@@ -76,9 +83,17 @@ sed -i 's,\r,,' $PKG/usr/doc/$PRGNAM-$VERSION/*
mv * $PKG/usr/share/games/$PRGNAM
ln -s ../share/games/$PRGNAM/$PRGNAM.py $PKG/usr/games/$PRGNAM
+for px in 16 32 48 64 128; do
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ convert -background none -resize $size \
+ $PKG/usr/share/games/$PRGNAM/data/images/misc/icon.svg \
+ $dir/$PRGNAM.png
+done
+
mkdir -p $PKG/usr/share/pixmaps
-ln -s ../games/$PRGNAM/data/images/misc/icon.png \
- $PKG/usr/share/pixmaps/$PRGNAM.png
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
# .desktop file written for this SlackBuild
mkdir -p $PKG/usr/share/applications