summaryrefslogtreecommitdiffstats
path: root/games/pcsx2/pcsx2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/pcsx2/pcsx2.SlackBuild')
-rw-r--r--games/pcsx2/pcsx2.SlackBuild126
1 files changed, 51 insertions, 75 deletions
diff --git a/games/pcsx2/pcsx2.SlackBuild b/games/pcsx2/pcsx2.SlackBuild
index d14eaca56f..66588a054f 100644
--- a/games/pcsx2/pcsx2.SlackBuild
+++ b/games/pcsx2/pcsx2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pcsx2
-# Copyright 2016-2018, 2020 Hunter Sezen California, USA
+# Copyright 2022 Steven Voges <Oregon, USA>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,16 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pcsx2
-VERSION=${VERSION:-1.6.0}
+VERSION=${VERSION:-1.7.3526}
+COMMIT=$(echo $VERSION | cut -c 5-)
+SRCVER=${SRCVER:-808fadd0617e0259a6a48a23d83005241bc0a739}
+GLSLANG=${GLSLANG:-c9706bdda0ac22b9856f1aa8261e5b9e15cd20c5}
+LIBCHDR=${LIBCHDR:-5de1a59019815ccdbba0fe07c71b31406d023248}
+VULKANHEADERS=${VULKANHEADERS:-9f4c61a31435a7a90a314fc68aeb386c92a09c0f}
+ACHIEVEMENTS=$ACHIEVEMENTS=:-ON}
+DISCORD=${DISCORD:-OFF}
+QT=${QT:-OFF}
+WAYLAND=${WAYLAND:-ON}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +47,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -49,29 +55,41 @@ fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+DEPS=$TMP/$PRGNAM-$SRCVER/3rdparty
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=core2"
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
-set -eu
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
+
+tar xvf $CWD/glslang-$GLSLANG.tar.gz -C \
+ $DEPS/glslang/glslang --strip-components 1
+tar xvf $CWD/libchdr-$LIBCHDR.tar.gz -C \
+ $DEPS/libchdr/libchdr --strip-components 1
+tar xvf $CWD/Vulkan-Headers-$VULKANHEADERS.tar.gz -C \
+ $DEPS/vulkan-headers --strip-components 1
+
+sed -i "s/#define PCSX2_VersionLo 0/#define PCSX2_VersionLo ${COMMIT}/g" \
+ pcsx2/SysForwardDefs.h
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -79,89 +97,47 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# pcsx2 does not support x86_64 yet and does
-# not plan to for the foreseeable future.
-BINDIR=; MULTILIB=
-if [ "$ARCH" = 'x86_64' ]; then
- BINDIR='/32'
- MULTILIB='-DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-i386-multilib.cmake'
-fi
-
-RELEASE=Debug
-
-if [ "${DEVEL:-0}" != 0 ]; then
- DEBUG=1
- RELEASE=Devel
-fi
-
-if [ "${DEBUG:=0}" != 0 ]; then
- [ "${ASAN:=FALSE}" != FALSE ] && ASAN=TRUE
- SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
-else
- ASAN=FALSE
- RELEASE=Release
-fi
-
-[ "${EGL_API:=OFF}" != OFF ] && EGL_API=ON
-
-# Handle this in doinst.sh instead
-# https://github.com/PCSX2/pcsx2/issues/2699
-sed -i '/setcap/d' pcsx2/CMakeLists.txt
-
-# Use a font included with Slackware
-# osd error: 'Failed to init the freetype face'
-sed -i \
- 's|truetype/freefont/FreeSerif.ttf|TTF/LiberationSerif-Regular.ttf|' \
- plugins/GSdx/GSdx.cpp
-
-# spu2-x: Make portaudio an optional dependency.
-# https://github.com/PCSX2/pcsx2/pull/3110
-# https://github.com/PCSX2/pcsx2/commit/84d090e2fde50c66b965b84c73abd9f04a1770dd
-patch -p1 < $CWD/portaudio.patch
-
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
+ -Wno-dev \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DDOC_DIR=/usr/doc/$PRGNAM-$VERSION \
- -DMAN_DIR=/usr/man \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin${BINDIR}/wx-config \
- -DwxWidgets_wxrc_EXECUTABLE=/usr/bin${BINDIR}/wxrc-3.0 \
- -DBUILD_REPLAY_LOADERS=TRUE \
- -DDISABLE_BUILD_DATE=ON \
- -DGSDX_LEGACY=ON \
+ -DCMAKE_BUILD_STRIP=ON \
+ -DDISABLE_PCSX2_WRAPPER=ON \
+ -DDISABLE_SETCAP=ON \
+ -DENABLE_TESTS=OFF \
-DPACKAGE_MODE=ON \
+ -DQT_BUILD=$QT \
+ -DUSE_DISCORD_PRESENCE=$DISCORD \
+ -DUSE_SYSTEM_LIBS=ON \
+ -DUSE_VULKAN=ON \
+ -DWAYLAND_API=$WAYLAND \
-DXDG_STD=ON \
- -DEGL_API=$EGL_API \
- -DUSE_ASAN=$ASAN \
- $MULTILIB \
- -DCMAKE_BUILD_TYPE=$RELEASE ..
+ -DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-if [ "$DEBUG" = 0 ]; then
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-fi
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a pcsx2/Docs/* bin/docs/*.html bin/docs/*.txt CONTRIBUTING.md COPYING* \
- README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.* README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/share/doc/Pcsx2/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -r $PKG/usr/share/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
-# Fix doinst.sh for x86_64
-[ "$ARCH" != 'x86_64' ] ||
- sed -i 's|-loaders |-loaders-32 |' $PKG/install/doinst.sh
-
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE