summaryrefslogtreecommitdiffstats
path: root/games/nestopia/nestopia.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/nestopia/nestopia.SlackBuild')
-rw-r--r--games/nestopia/nestopia.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/games/nestopia/nestopia.SlackBuild b/games/nestopia/nestopia.SlackBuild
index 6b0142349d..f45e53f233 100644
--- a/games/nestopia/nestopia.SlackBuild
+++ b/games/nestopia/nestopia.SlackBuild
@@ -5,7 +5,7 @@
# Written by Dugan Chen (thedoogster@gmail.com)
PRGNAM=nestopia
-VERSION=${VERSION:-1.46}
+VERSION=${VERSION:-1.46.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -48,10 +48,10 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch < $CWD/Makefile.patch
sed -i "s/-O3 -g3/-g3 ${SLKCFLAGS}/g" Makefile
@@ -62,9 +62,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING README.md README.unix changelog.txt readme.html \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md README.unix changelog.txt readme.html $PKG/usr/doc/$PRGNAM-$VERSION
cp -ar doc/ $PKG/usr/doc/$PRGNAM-$VERSION/api/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild