summaryrefslogtreecommitdiffstats
path: root/games/glbsp/fltkconf.diff
diff options
context:
space:
mode:
Diffstat (limited to 'games/glbsp/fltkconf.diff')
-rw-r--r--games/glbsp/fltkconf.diff29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/glbsp/fltkconf.diff b/games/glbsp/fltkconf.diff
new file mode 100644
index 0000000000..de68545c36
--- /dev/null
+++ b/games/glbsp/fltkconf.diff
@@ -0,0 +1,29 @@
+diff -Naur glbsp-2.24-source/Makefile.unx glbsp-2.24-source.patched/Makefile.unx
+--- glbsp-2.24-source/Makefile.unx 2007-07-25 23:14:34.000000000 -0400
++++ glbsp-2.24-source.patched/Makefile.unx 2015-11-26 07:20:52.012999000 -0500
+@@ -94,9 +94,8 @@
+
+ # ----- GUI PROGRAM ---------------------------------------------
+
+-FLTK_FLAGS=-I$(FLTK_DIR) -I$(FLTK_DIR)/zlib
+-FLTK_LIBS=-L$(FLTK_DIR)/lib -lfltk_images -lpng -lz -ljpeg \
+- -lfltk -lX11 -lXext
++FLTK_FLAGS=$(shell fltk-config --cflags)
++FLTK_LIBS=$(shell fltk-config --use-images --ldflags)
+
+ ## may need: -L/usr/X11R6/lib
+
+diff -Naur glbsp-2.24-source/nodeview/Makefile.unx glbsp-2.24-source.patched/nodeview/Makefile.unx
+--- glbsp-2.24-source/nodeview/Makefile.unx 2007-05-21 09:17:03.000000000 -0400
++++ glbsp-2.24-source.patched/nodeview/Makefile.unx 2015-11-26 07:23:19.660999000 -0500
+@@ -7,8 +7,8 @@
+ BIN=nodeview
+ SRC_DIR=nodeview
+
+-FLTK_CFLAGS=-I/usr/local/lib
+-FLTK_LIBS=-lfltk_images -lfltk -lX11 -lXext -lpng -ljpeg
++FLTK_CFLAGS=$(shell fltk-config --cflags)
++FLTK_LIBS=$(shell fltk-config --use-images --ldflags)
+
+ CC=gcc
+ CXX=g++