summaryrefslogtreecommitdiffstats
path: root/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch')
-rw-r--r--games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch b/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
new file mode 100644
index 0000000000..6450c91f32
--- /dev/null
+++ b/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
@@ -0,0 +1,22 @@
+From d14f232f4cd9a00b05d6872957070e8c020f515d Mon Sep 17 00:00:00 2001
+From: Thomas Kowaliczek-Schmer <linuxdonald@posteo.de>
+Date: Wed, 22 May 2019 16:04:43 +0200
+Subject: [PATCH] removed flags that are not supported with swig 4.0
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 126322ce0..25c695630 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -893,7 +893,7 @@ if(build-python)
+ find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
+ include_directories(${PYTHON_INCLUDE_PATH})
+
+- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
++ set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314)
+
+ set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
+ set(FIFE_SOURCES ${FIFE_CORE_SRC})