summaryrefslogtreecommitdiffstats
path: root/games/fceux/fceux.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/fceux/fceux.SlackBuild')
-rw-r--r--games/fceux/fceux.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/fceux/fceux.SlackBuild b/games/fceux/fceux.SlackBuild
index d8ab3875be..f856ad9b91 100644
--- a/games/fceux/fceux.SlackBuild
+++ b/games/fceux/fceux.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fceux
-VERSION=${VERSION:-2.4.0}
+VERSION=${VERSION:-2.6.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -79,9 +79,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix man pages
-sed -i 's,share/man/man6,man/man6,g' src/CMakeLists.txt
-
# Fix incorrect version name
sed -i 's/-interim git//g' src/version.h
@@ -92,12 +89,15 @@ cd build
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
+# remove unused files
+rm -rf $PKG/usr/share/$PRGNAM/*.dll
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true