summaryrefslogtreecommitdiffstats
path: root/games/crrcsim
diff options
context:
space:
mode:
Diffstat (limited to 'games/crrcsim')
-rw-r--r--games/crrcsim/crrcsim.SlackBuild3
-rw-r--r--games/crrcsim/fix_bug.patch12
2 files changed, 15 insertions, 0 deletions
diff --git a/games/crrcsim/crrcsim.SlackBuild b/games/crrcsim/crrcsim.SlackBuild
index ab12c3bab1..67fc8d4734 100644
--- a/games/crrcsim/crrcsim.SlackBuild
+++ b/games/crrcsim/crrcsim.SlackBuild
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# https://aur.archlinux.org/packages/crrcsim/#comment-668700
+patch -p1 < $CWD/fix_bug.patch
+
# Boost libraries are now threadsafe; -mt has been dropped
sed -i 's/boost_thread-mt/boost_thread/g' configure.ac
./autogen.sh
diff --git a/games/crrcsim/fix_bug.patch b/games/crrcsim/fix_bug.patch
new file mode 100644
index 0000000000..b8eadeece9
--- /dev/null
+++ b/games/crrcsim/fix_bug.patch
@@ -0,0 +1,12 @@
+diff -ru crrcsim-0.9.13.old/src/mod_video/crrc_animation.cpp crrcsim-0.9.13/src/mod_video/crrc_animation.cpp
+--- crrcsim-0.9.13.old/src/mod_video/crrc_animation.cpp 2016-04-10 09:57:14.000000000 -0700
++++ crrcsim-0.9.13/src/mod_video/crrc_animation.cpp 2018-10-30 16:13:09.055770007 -0700
+@@ -84,7 +84,7 @@
+ else
+ {
+ std::cerr << "createAnimation: unknown animation type \'"
+- << type << "\'" << std::cerr;
++ << type << "\'" << std::endl;
+ }
+
+ if (anim != NULL)