summaryrefslogtreecommitdiffstats
path: root/games/antares/text.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/antares/text.patch')
-rw-r--r--games/antares/text.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/antares/text.patch b/games/antares/text.patch
new file mode 100644
index 0000000000..62b7e61ba2
--- /dev/null
+++ b/games/antares/text.patch
@@ -0,0 +1,26 @@
+From 914ad7b2cd53b8396a6e407c91b63adfc3b18443 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Wed, 8 Jan 2020 07:42:21 -0800
+Subject: [PATCH] Makefile: Install the text directory.
+
+This fixes a crash at the end of the tutorial level.
+
+antares-glfw: text/6000.txt: couldn't find resource "text/6000.txt"
+
+Signed-off-by: orbea <orbea@riseup.net>
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index 7146731e..7404fb34 100644
+--- a/Makefile
++++ b/Makefile
+@@ -105,6 +105,7 @@ install-data: build
+ cp -r data/sounds $(DESTDIR)$(DATADIR)/app
+ cp -r data/sprites $(DESTDIR)$(DATADIR)/app
+ cp -r data/strings $(DESTDIR)$(DATADIR)/app
++ cp -r data/text $(DESTDIR)$(DATADIR)/app
+
+ .PHONY: install-scenario
+ install-scenario: build