summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
Diffstat (limited to 'development')
-rw-r--r--development/Sphinx/README5
-rw-r--r--development/Sphinx/Sphinx.SlackBuild84
-rw-r--r--development/Sphinx/Sphinx.info10
-rw-r--r--development/Sphinx/slack-desc19
-rw-r--r--development/android-tools/android-tools.SlackBuild5
-rw-r--r--development/android-tools/patches/0012-CMakeLists.txt-Disable-Werror-by-default.patch24
-rw-r--r--development/android-tools/patches/0021-tls-include-functional.patch22
-rw-r--r--development/codelite/codelite.SlackBuild4
-rw-r--r--development/codelite/codelite.info6
-rw-r--r--development/device-tree-compiler/device-tree-compiler.SlackBuild4
-rw-r--r--development/device-tree-compiler/device-tree-compiler.info6
-rw-r--r--development/gambas3/gambas3.SlackBuild1
-rw-r--r--development/nodejs/README8
-rw-r--r--development/nodejs/nodejs.SlackBuild125
-rw-r--r--development/nodejs/nodejs.info10
-rw-r--r--development/nodejs/npm.sh58
-rw-r--r--development/nodejs/slack-desc19
-rw-r--r--development/protobuf3/gcc12.patch24
-rw-r--r--development/protobuf3/protobuf3.SlackBuild1
-rw-r--r--development/splint/splint.SlackBuild5
-rw-r--r--development/unittest-cpp/unittest-cpp.SlackBuild2
21 files changed, 89 insertions, 353 deletions
diff --git a/development/Sphinx/README b/development/Sphinx/README
deleted file mode 100644
index e3f923a7f7..0000000000
--- a/development/Sphinx/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Sphinx is a tool that translates a set of reStructuredText
-source files into various output formats, including HTML, ePub,
-LaTeX and plain text. Sphinx was originally created for the Python
-documentation, but it has excellent facilities for the documentation
-of software projects in a range of languages.
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
deleted file mode 100644
index 87caf8736b..0000000000
--- a/development/Sphinx/Sphinx.SlackBuild
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Sphinx
-
-# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Sphinx
-VERSION=${VERSION:-4.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS CHANGES EXAMPLES LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
deleted file mode 100644
index f2c4274ca9..0000000000
--- a/development/Sphinx/Sphinx.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Sphinx"
-VERSION="4.2.0"
-HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-4.2.0.tar.gz"
-MD5SUM="6af34550e36dd6d58a496e47ec67280f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/Sphinx/slack-desc b/development/Sphinx/slack-desc
deleted file mode 100644
index 403648f0ae..0000000000
--- a/development/Sphinx/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Sphinx: Sphinx (Documentation generator)
-Sphinx:
-Sphinx: Sphinx is a tool that translates a set of reStructuredText source
-Sphinx: files into various output formats, including HTML, ePub, LaTeX and
-Sphinx: plain text. Sphinx was originally created for the Python
-Sphinx: documentation, but it has excellent facilities for the documentation
-Sphinx: of software projects in a range of languages.
-Sphinx:
-Sphinx:
-Sphinx:
-Sphinx:
diff --git a/development/android-tools/android-tools.SlackBuild b/development/android-tools/android-tools.SlackBuild
index c858d18140..7096067f4c 100644
--- a/development/android-tools/android-tools.SlackBuild
+++ b/development/android-tools/android-tools.SlackBuild
@@ -81,6 +81,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+( cd vendor/adb
+ patch -p1 < $CWD/patches/0021-tls-include-functional.patch )
+( cd vendor/boringssl
+ patch -p1 < $CWD/patches/0012-CMakeLists.txt-Disable-Werror-by-default.patch )
+
export GOCACHE=$(pwd)/build/go-cache
export GO111MODULE=off
diff --git a/development/android-tools/patches/0012-CMakeLists.txt-Disable-Werror-by-default.patch b/development/android-tools/patches/0012-CMakeLists.txt-Disable-Werror-by-default.patch
new file mode 100644
index 0000000000..c9ac7ff3b3
--- /dev/null
+++ b/development/android-tools/patches/0012-CMakeLists.txt-Disable-Werror-by-default.patch
@@ -0,0 +1,24 @@
+From 9ecab80323875e95b08b5e6f327e4d5bd5d70478 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Sat, 21 May 2022 11:47:32 +0200
+Subject: [PATCH] CMakeLists.txt: Disable -Werror by default
+
+Boringssl regularly fails to compile with newer GCC versions due
+to new warnings introduced by GCC upstream.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f58e853cd..b1fec9616 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -117,7 +117,7 @@ endif()
+ if(CMAKE_COMPILER_IS_GNUCXX OR CLANG)
+ # Note clang-cl is odd and sets both CLANG and MSVC. We base our configuration
+ # primarily on our normal Clang one.
+- set(C_CXX_FLAGS "-Werror -Wformat=2 -Wsign-compare -Wmissing-field-initializers -Wwrite-strings -Wvla")
++ set(C_CXX_FLAGS "-Wformat=2 -Wsign-compare -Wmissing-field-initializers -Wwrite-strings -Wvla")
+ if(MSVC)
+ # clang-cl sets different default warnings than clang. It also treats -Wall
+ # as -Weverything, to match MSVC. Instead -W3 is the alias for -Wall.
diff --git a/development/android-tools/patches/0021-tls-include-functional.patch b/development/android-tools/patches/0021-tls-include-functional.patch
new file mode 100644
index 0000000000..8b4a517021
--- /dev/null
+++ b/development/android-tools/patches/0021-tls-include-functional.patch
@@ -0,0 +1,22 @@
+From 9d0394f52324e7ccc62c67ce34cfe6ef9e85f043 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Wed, 18 May 2022 01:02:57 +0200
+Subject: [PATCH] tls: include <functional>
+
+Fixes compilation with GCC 12.1.
+---
+ tls/include/adb/tls/tls_connection.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tls/include/adb/tls/tls_connection.h b/tls/include/adb/tls/tls_connection.h
+index bc5b98ab..a112756c 100644
+--- a/tls/include/adb/tls/tls_connection.h
++++ b/tls/include/adb/tls/tls_connection.h
+@@ -19,6 +19,7 @@
+ #include <stddef.h>
+ #include <stdint.h>
+
++#include <functional>
+ #include <string_view>
+ #include <vector>
+
diff --git a/development/codelite/codelite.SlackBuild b/development/codelite/codelite.SlackBuild
index a73a0361d7..8c14bbd4fd 100644
--- a/development/codelite/codelite.SlackBuild
+++ b/development/codelite/codelite.SlackBuild
@@ -7,8 +7,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=codelite
-VERSION=${VERSION:-15.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-16.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
diff --git a/development/codelite/codelite.info b/development/codelite/codelite.info
index c01b8a1ba5..04c9ae1ec9 100644
--- a/development/codelite/codelite.info
+++ b/development/codelite/codelite.info
@@ -1,8 +1,8 @@
PRGNAM="codelite"
-VERSION="15.0"
+VERSION="16.0.0"
HOMEPAGE="http://www.codelite.org/"
-DOWNLOAD="https://github.com/eranif/codelite/archive/15.0/codelite-15.0.tar.gz"
-MD5SUM="1c54744ab0c9b5732087687ab17ab49d"
+DOWNLOAD="https://github.com/eranif/codelite/archive/16.0.0/codelite-16.0.0.tar.gz"
+MD5SUM="0141a38d2f686520d54fd19a6df0fac3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="wxGTK3"
diff --git a/development/device-tree-compiler/device-tree-compiler.SlackBuild b/development/device-tree-compiler/device-tree-compiler.SlackBuild
index 28a9bf3c40..7ec001ee23 100644
--- a/development/device-tree-compiler/device-tree-compiler.SlackBuild
+++ b/development/device-tree-compiler/device-tree-compiler.SlackBuild
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=device-tree-compiler
-VERSION=${VERSION:-1.6.1}
+VERSION=${VERSION:-20220420_ed31080}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -74,7 +74,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
diff --git a/development/device-tree-compiler/device-tree-compiler.info b/development/device-tree-compiler/device-tree-compiler.info
index a25d77bae3..326e24228c 100644
--- a/development/device-tree-compiler/device-tree-compiler.info
+++ b/development/device-tree-compiler/device-tree-compiler.info
@@ -1,8 +1,8 @@
PRGNAM="device-tree-compiler"
-VERSION="1.6.1"
+VERSION="20220420_ed31080"
HOMEPAGE="https://git.kernel.org/cgit/utils/dtc/dtc.git"
-DOWNLOAD="https://git.kernel.org/pub/scm/utils/dtc/dtc.git/snapshot/dtc-1.6.1.tar.gz"
-MD5SUM="19eef37196e99b659c402a29aac5ba59"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/dtc-20220420_ed31080.tar.xz"
+MD5SUM="e9645746d8e3e21cda57b474dbc82acf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/development/gambas3/gambas3.SlackBuild b/development/gambas3/gambas3.SlackBuild
index 4b7d2c1cc9..7912879184 100644
--- a/development/gambas3/gambas3.SlackBuild
+++ b/development/gambas3/gambas3.SlackBuild
@@ -91,6 +91,7 @@ LLVM_CONFIG=llvm-config \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--build=$ARCH-slackware-linux \
+ --disable-pdf \
$qt5
make
diff --git a/development/nodejs/README b/development/nodejs/README
deleted file mode 100644
index 19aa105720..0000000000
--- a/development/nodejs/README
+++ /dev/null
@@ -1,8 +0,0 @@
-Node.js is a JavaScript runtime built on Chrome's V8 JavaScript engine.
-
-Node.js uses an event-driven, non-blocking I/O model that makes it
-lightweight and efficient. Node.js' package ecosystem, npm, is the
-largest ecosystem of open source libraries in the world.
-
-NOTE: This version uses an internal OpenSSL version instead of
-the one provided in Slackware package.
diff --git a/development/nodejs/nodejs.SlackBuild b/development/nodejs/nodejs.SlackBuild
deleted file mode 100644
index 9a6c8c77a3..0000000000
--- a/development/nodejs/nodejs.SlackBuild
+++ /dev/null
@@ -1,125 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for nodejs
-# Thanks to Audrius Kažukauskas
-
-# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
-# Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version, with the following exception:
-# the text of the GPL license may be omitted.
-
-# This program is distributed in the hope that it will be useful, but
-# without any warranty; without even the implied warranty of
-# merchantability or fitness for a particular purpose. Compiling,
-# interpreting, executing or merely reading the text of the program
-# may result in lapses of consciousness and/or very being, up to and
-# including the end of all existence and the Universe as we know it.
-# See the GNU General Public License for more details.
-
-# You may have received a copy of the GNU General Public License
-# along with this program (most likely, a file named COPYING). If
-# not, see <https://www.gnu.org/licenses/>.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=nodejs
-SRCNAM=node
-VERSION=${VERSION:-18.7.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-v$VERSION
-tar xvf $CWD/$SRCNAM-v$VERSION.tar.xz
-cd $SRCNAM-v$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-## Fix man page path.
-sed -i 's|share/||' tools/install.py
-
-## Fix libdir for 64-bit.
-sed -i "s|lib/|lib${LIBDIRSUFFIX}/|g" tools/install.py
-sed -i "s/'lib'/'lib${LIBDIRSUFFIX}'/" \
- lib/module.js \
- lib/internal/modules/cjs/loader.js \
- deps/npm/lib/npm.js
-
-sed -i "s|math.h|cmath|" src/node_crypto.cc
-./configure \
- --prefix=/usr \
- --shared-zlib \
- --ninja
-
-make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-## Add bash completion file for npm.
-install -D -m 644 $CWD/npm.sh $PKG/usr/share/bash-completion/completions/npm
-
-## Remove unneeded files.
-find $PKG/usr \( -name '.git*' \) -exec rm -f {} \;
-
-# Fix some files path
-mv $PKG/usr/doc/node $PKG/usr/share/nodejs
-mv $PKG/usr/systemtap $PKG/usr/share/systemtap
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE *.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/nodejs/nodejs.info b/development/nodejs/nodejs.info
deleted file mode 100644
index 0c1f0583b3..0000000000
--- a/development/nodejs/nodejs.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="nodejs"
-VERSION="18.7.0"
-HOMEPAGE="https://nodejs.org/"
-DOWNLOAD="https://nodejs.org/dist/v18.7.0/node-v18.7.0.tar.xz"
-MD5SUM="027b8f20dd24918fbc8867de13c1540f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Willy Sudiarto Raharjo"
-EMAIL="willysr@slackbuilds.org"
diff --git a/development/nodejs/npm.sh b/development/nodejs/npm.sh
deleted file mode 100644
index 25bef2c17b..0000000000
--- a/development/nodejs/npm.sh
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/bash
-###-begin-npm-completion-###
-#
-# npm command completion script
-#
-# Installation: npm completion >> ~/.bashrc (or ~/.zshrc)
-# Or, maybe: npm completion > /usr/local/etc/bash_completion.d/npm
-#
-
-if type complete &>/dev/null; then
- _npm_completion () {
- local words cword
- if type _get_comp_words_by_ref &>/dev/null; then
- _get_comp_words_by_ref -n = -n @ -w words -i cword
- else
- cword="$COMP_CWORD"
- words=("${COMP_WORDS[@]}")
- fi
-
- local si="$IFS"
- IFS=$'\n' COMPREPLY=($(COMP_CWORD="$cword" \
- COMP_LINE="$COMP_LINE" \
- COMP_POINT="$COMP_POINT" \
- npm completion -- "${words[@]}" \
- 2>/dev/null)) || return $?
- IFS="$si"
- }
- complete -o default -F _npm_completion npm
-elif type compdef &>/dev/null; then
- _npm_completion() {
- local si=$IFS
- compadd -- $(COMP_CWORD=$((CURRENT-1)) \
- COMP_LINE=$BUFFER \
- COMP_POINT=0 \
- npm completion -- "${words[@]}" \
- 2>/dev/null)
- IFS=$si
- }
- compdef _npm_completion npm
-elif type compctl &>/dev/null; then
- _npm_completion () {
- local cword line point words si
- read -Ac words
- read -cn cword
- let cword-=1
- read -l line
- read -ln point
- si="$IFS"
- IFS=$'\n' reply=($(COMP_CWORD="$cword" \
- COMP_LINE="$line" \
- COMP_POINT="$point" \
- npm completion -- "${words[@]}" \
- 2>/dev/null)) || return $?
- IFS="$si"
- }
- compctl -K _npm_completion npm
-fi
-###-end-npm-completion-###
diff --git a/development/nodejs/slack-desc b/development/nodejs/slack-desc
deleted file mode 100644
index bb10691042..0000000000
--- a/development/nodejs/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-nodejs: nodejs (JavaScript runtime)
-nodejs:
-nodejs: Node.js is a JavaScript runtime built on Chrome's V8 JavaScript
-nodejs: engine.
-nodejs:
-nodejs: https://nodejs.org/
-nodejs:
-nodejs:
-nodejs:
-nodejs:
-nodejs:
diff --git a/development/protobuf3/gcc12.patch b/development/protobuf3/gcc12.patch
new file mode 100644
index 0000000000..866977ecdb
--- /dev/null
+++ b/development/protobuf3/gcc12.patch
@@ -0,0 +1,24 @@
+From b180b2809f7e77fdf7dd075d26a7421085bac58f Mon Sep 17 00:00:00 2001
+From: Adam Cozzette <acozzette@google.com>
+Date: Mon, 9 May 2022 13:15:44 -0700
+Subject: [PATCH] Use __constinit only in GCC 12.2 and up (#9936)
+
+Fixes #9916. GCC appears to have a bug preventing our use of __constinit
+from working correctly, but this bug will be fixed in GCC 12.2.
+---
+ src/google/protobuf/port_def.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/google/protobuf/port_def.inc b/src/google/protobuf/port_def.inc
+index dcb0ff758f..289a42674c 100644
+--- a/src/google/protobuf/port_def.inc
++++ b/src/google/protobuf/port_def.inc
+@@ -650,7 +650,7 @@
+ (!defined(__APPLE__) && __clang_major__ >= 12))
+ #define PROTOBUF_CONSTINIT [[clang::require_constant_initialization]]
+ #define PROTOBUF_CONSTEXPR constexpr
+-#elif PROTOBUF_GNUC_MIN(12, 0)
++#elif PROTOBUF_GNUC_MIN(12, 2)
+ #define PROTOBUF_CONSTINIT __constinit
+ #define PROTOBUF_CONSTEXPR constexpr
+ #else
diff --git a/development/protobuf3/protobuf3.SlackBuild b/development/protobuf3/protobuf3.SlackBuild
index 0cef90a454..13395478c8 100644
--- a/development/protobuf3/protobuf3.SlackBuild
+++ b/development/protobuf3/protobuf3.SlackBuild
@@ -85,6 +85,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/protobuf3.patch
+patch -p1 < $CWD/gcc12.patch
./autogen.sh
CFLAGS="$SLKCFLAGS" \
diff --git a/development/splint/splint.SlackBuild b/development/splint/splint.SlackBuild
index e7cf5025a8..1f0b956521 100644
--- a/development/splint/splint.SlackBuild
+++ b/development/splint/splint.SlackBuild
@@ -67,10 +67,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-automake --add-missing || true
-autoreconf || true
-automake --add-missing
-autoreconf
+autoreconf -vif
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/development/unittest-cpp/unittest-cpp.SlackBuild b/development/unittest-cpp/unittest-cpp.SlackBuild
index 061e9fea38..223216bb2e 100644
--- a/development/unittest-cpp/unittest-cpp.SlackBuild
+++ b/development/unittest-cpp/unittest-cpp.SlackBuild
@@ -84,7 +84,7 @@ mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -Wno-error=uninitialized" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DCMAKE_BUILD_TYPE=Release ..