summaryrefslogtreecommitdiffstats
path: root/development/pudb
diff options
context:
space:
mode:
Diffstat (limited to 'development/pudb')
-rw-r--r--development/pudb/GETTING_STARTED12
-rw-r--r--development/pudb/README31
-rw-r--r--development/pudb/pudb.SlackBuild119
-rw-r--r--development/pudb/pudb.info14
4 files changed, 51 insertions, 125 deletions
diff --git a/development/pudb/GETTING_STARTED b/development/pudb/GETTING_STARTED
new file mode 100644
index 0000000000..b14afe4a6c
--- /dev/null
+++ b/development/pudb/GETTING_STARTED
@@ -0,0 +1,12 @@
+GETTING STARTED
+
+Please see starting.rst usage.rst misc.rst and shells.rst in
+/usr/doc/pudb-$VERSION to get started, and also -
+
+Online docs:
+
+https://documen.tician.de/pudb/
+
+A simple, but useful, illustrated example page:
+
+http://heather.cs.ucdavis.edu/~matloff/pudb.html
diff --git a/development/pudb/README b/development/pudb/README
index 27b0f630b2..646d1f2736 100644
--- a/development/pudb/README
+++ b/development/pudb/README
@@ -6,36 +6,17 @@ to debug code right where you write and test it--in a terminal. If
you've worked with the excellent (but nowadays ancient) DOS-based
Turbo Pascal or C tools, PuDB's UI might look familiar.
-By default this SlackBuild builds the python2 debugger, and if
-python3 is detected, the python3 version too. The Pygments SlackBuild
-will automatically install for python3 too.
-
-NOTE: The python3 application is named pudb3. NOTE: You need
-python3-urwid and python3-Pygments installed to use pudb3.
-
OPTIONS
+Unless specified, both python2 and python3 versions will be built.
+
To *ONLY* build the python2 version, use:
-NO_PYTHON3=yes ./pudb.SlackBuild
+PYTHON3=no ./pudb.SlackBuild
To *ONLY* build the python3 version, use:
-NO_PYTHON2=yes ./pudb.SlackBuild
-
-The python2 version requires a newer version of urwid than the stock
-Slackware one, therefore this also builds a custom urwid named
-py2_urwid, which it can use. This should not conflict with the stock
-Slackware version.
-
-OPTIONAL DEPENDENCIES
-
-To use pudb3:
-
-python3-Pygments
-python3-urwid
-
-It will build without these so they can be installed later if needed.
+PYTHON2=no ./pudb.SlackBuild
#####################################################################
@@ -51,7 +32,3 @@ https://documen.tician.de/pudb/
A simple, but useful, illustrated example page:
http://heather.cs.ucdavis.edu/~matloff/pudb.html
-
-Github page:
-
-https://github.com/inducer/pudb
diff --git a/development/pudb/pudb.SlackBuild b/development/pudb/pudb.SlackBuild
index 9b3e70945b..09dc6152fa 100644
--- a/development/pudb/pudb.SlackBuild
+++ b/development/pudb/pudb.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
-#
+#!/bin/bash
+
# Slackware build script for pudb
-# Copyright 2018 David Woodfall <dave@dawoodfall.net>
+# Copyright 2018- Dave Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+if ! printf %s "${PYTHON2:=yes}${PYTHON3:=yes}" | grep -q "yes"; then
+ echo "Both python versions deselected. Nothing to do."
+ exit 1
+fi
+
PRGNAM=pudb
-VERSION=${VERSION:-2018.1}
-URWIDVER=2.0.1
+VERSION=${VERSION:-2020.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,66 +43,23 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-if [ "$NO_PYTHON2" = "yes" ] && [ "$NO_PYTHON3" = "yes" ]; then
- printf "%s\n" "You appear to not want to install anything."
- exit 1
-fi
-
-# see if we have python3 installed
-which python3 >/dev/null 2>&1 && PY3=1
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-
-# install custom urwid package
-if [ "$NO_PYTHON2" != "yes" ]; then
- rm -rf urwid-$URWIDVER
- tar xfv $CWD/urwid-$URWIDVER.tar.gz
- cd urwid-$URWIDVER
-
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
- # change the module name so our urwid doesn't call the stock version
- sed -i "s%'name':\"urwid\"%'name':\"py2_urwid\"%" setup.py
- sed -i "23 a import py2_urwid\n\
-import sys\n\
-sys.modules['urwid'] = py2_urwid" urwid/__init__.py
-
- python setup.py install --root=$PKG
-
- # rename it so it doesn't collide with the stock version
- mv $PKG/usr/lib$LIBDIRSUFFIX/python2.7/site-packages/urwid \
- $PKG/usr/lib$LIBDIRSUFFIX/python2.7/site-packages/py2_urwid
- cd ..
-fi
-
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
@@ -106,51 +70,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# install the python3 version before we wreck the python2 build
-if [ -n "$PY3" ] && [ "$NO_PYTHON3" != "yes" ]; then
- python3 setup.py install --root=$PKG
+if [ "${PYTHON2:=yes}" = "yes" ]; then
+ python2 setup.py install --root=$PKG
fi
-# install the edited python2 version
-if [ "$NO_PYTHON2" != "yes" ]; then
- # change all references to urwid to our custom py2_urwid
- for py in \
- settings.py \
- source_view.py \
- debugger.py \
- theme.py \
- __init__.py \
- ui_tools.py \
- var_view.py
- do
- sed -i "s%import urwid%import py2_urwid as urwid%g" pudb/$py
- done
-
- sed -i "s%urwid>=1.1.1%py2_urwid>=1.1.1%" setup.py
-
- # done so now install
- python setup.py install --root=$PKG
+if [ "${PYTHON3:=yes}" = "yes" ]; then
+ python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
- || true
-
# added more docs, some examples and a test debug script
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
-cp -a README.rst LICENSE \
- doc/starting.rst doc/usage.rst doc/misc.rst doc/shells.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a example-* debug_me.py try-the-debugger.sh \
+ $PKG/usr/doc/$PRGNAM-$VERSION/examples
-cp -a example-* debug_me.py $PKG/usr/doc/$PRGNAM-$VERSION/examples
+cp -a $CWD/GETTING_STARTED README.rst LICENSE doc/*.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-# this might come in handy later for someone
-cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.slackware
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/pudb/pudb.info b/development/pudb/pudb.info
index ec812760c4..cffafe3930 100644
--- a/development/pudb/pudb.info
+++ b/development/pudb/pudb.info
@@ -1,12 +1,10 @@
PRGNAM="pudb"
-VERSION="2018.1"
+VERSION="2020.1"
HOMEPAGE="https://pypi.python.org/pypi/pudb"
-DOWNLOAD="https://github.com/inducer/pudb/archive/v2018.1/pudb-2018.1.tar.gz \
- https://pypi.org/packages/source/u/urwid/urwid-2.0.1.tar.gz"
-MD5SUM="9d34d2bdcec48f1f94693f6ca8d3f7c3 \
- c70a7016fa1ad2c2a979dbebd4de78c2"
+DOWNLOAD="https://files.pythonhosted.org/packages/3d/bc/1947dc9dc54a44bc6cbff3556cd514258886a4a60e85aa32a3ba027098bc/pudb-2020.1.tar.gz"
+MD5SUM="7ee30f74b95b31ebe150c4837cc98d2f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Pygments"
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
+REQUIRES="python-urwid"
+MAINTAINER="D Woodfall"
+EMAIL="dave@slackbuilds.org"