summaryrefslogtreecommitdiffstats
path: root/development/mysql-workbench/mysql-workbench.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/mysql-workbench/mysql-workbench.SlackBuild')
-rw-r--r--development/mysql-workbench/mysql-workbench.SlackBuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/development/mysql-workbench/mysql-workbench.SlackBuild b/development/mysql-workbench/mysql-workbench.SlackBuild
index e2bf29b2d7..9297558afc 100644
--- a/development/mysql-workbench/mysql-workbench.SlackBuild
+++ b/development/mysql-workbench/mysql-workbench.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for mysql-workbench
# Originally written by André Geraldo Vieira <andre.geraldo@gmail.com>
-# Copyright 2013-2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mysql-workbench
-VERSION=${VERSION:-6.2.5}
+VERSION=${VERSION:-6.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -75,12 +75,11 @@ find -L . \
# Patch from Ponce
patch -p1 < $CWD/config_and_ifconfig_paths.patch
-# fix schema and table inspector with mysql-connector-c++ >= 1.1.5
-# still not really working, so mysql-connector-c++ is kept at 1.1.3
-patch -p1 < $CWD/mysql-workbench-column-label.patch
-
# Patch to fix gdal include path
-patch -p1 < $CWD/workbench-gdal.patch
+sed -i '/#include/s|gdal/||' \
+ backend/wbpublic/grtui/geom_draw_box.h \
+ backend/wbpublic/grt/spatial_handler.h \
+ backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
# mysqldump from mariadb does not support --set-gtid-purged
patch -p1 < $CWD/mysql-workbench-no-set-gtid-purged.patch
@@ -90,8 +89,13 @@ patch -p1 < $CWD/mysql-workbench-no-set-gtid-purged.patch
# gnome-keyring package in stable release as well
patch -p1 < $CWD/mysql-workbench-gnome-keyring.patch
+patch -p1 < $CWD/mysql-workbench-no-json.patch
+
install -D $CWD/antlr-3.4-complete.jar $TMP/linux-res/bin/antlr-3.4-complete.jar
+# make cmake happy with mariadb
+sed -i '/^find_package(MySQL /c find_package(MySQL REQUIRED)' CMakeLists.txt
+
mkdir -p wb-build
cd wb-build
cmake \
@@ -102,6 +106,7 @@ cmake \
-DPYTHON_INCLUDE_DIR:PATH=/usr/include/python2.7 \
-DPYTHON_LIBRARY:FILEPATH=/usr/lib$LIBDIRSUFFIX/libpython2.7.so \
-DGDAL_INCLUDE_DIR=/usr/include \
+ -DCMAKE_CXX_FLAGS="-std=c++11" \
-DCMAKE_BUILD_TYPE=Release ..
make